{"answers":{"affected":"2 open source packages ship an affected version, including laravel/pulse. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55661 exists.","fix":"Upgrade laravel/pulse to 1.3.1 or later.","what":"CVE-2024-55661 is a high-severity code injection vulnerability in laravel pulse, published on 13 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-55661 and fix it if it is affected.\n\nWhat it is: CVE-2024-55661 is a high-severity code injection vulnerability in laravel pulse, published on 13 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55661 exists.\n\nAffected packages and fixed versions:\n- laravel/pulse (Packagist): affected all versions; fixed in 1.3.1\n- laravel/pulse (Packagist): affected all versions; fixed in 1.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-55661/ (Markdown: https://insights.sbomify.com/CVE-2024-55661/index.md)","id":"CVE-2024-55661","markdown":"https://insights.sbomify.com/CVE-2024-55661/index.md","name":"CVE-2024-55661","record":{"aliases":["GHSA-8vwh-pr89-4mw2"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel Pulse monitoring","requires_auth":"low_privilege","summary":"Authenticated users can execute arbitrary code via the unprotected remember method in Laravel Pulse dashboard components.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pulse","vendor":"laravel"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Laravel Pulse is a real-time application performance monitoring tool and dashboard for Laravel applications. A vulnerability has been discovered in Laravel Pulse prior to version 1.3.1 that could allow remote code execution through the public `remember()` method in the `Laravel\\Pulse\\Livewire\\Concerns\\RemembersQueries` trait. This method is accessible via Livewire components and can be exploited to call arbitrary callables within the application. An authenticated user with access to Laravel Pulse dashboard can execute arbitrary code by calling any function or static method in which the callable is a function or static method and the callable has no parameters or no strict parameter types. The vulnerable to component is `remember(callable $query, string $key = '')` method in `Laravel\\Pulse\\Livewire\\Concerns\\RemembersQueries`, and the vulnerability affects all Pulse card components that use this trait. Version 1.3.1 contains a patch.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2025-06-09","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-06-09","kind":"exploitdb","ref":"52319","stars":null,"title":"Laravel Pulse 1.3.1 - Arbitrary Code Injection"}],"tier":"weaponised"},"has_fix":true,"headline":"Laravel Pulse Allows Remote Code Execution via Unprotected Query Method","id":"CVE-2024-55661","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"XWiki allows remote code execution through the extension sheet","id":"CVE-2024-55662"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"laravel/pulse","purl":null,"source":"GHSA-8vwh-pr89-4mw2"},{"ecosystem":"Packagist","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"laravel/pulse","purl":"pkg:composer/laravel/pulse","source":"GHSA-8vwh-pr89-4mw2"}],"prev":{"headline":"SiYuan has an SSTI via /api/template/renderSprig","id":"CVE-2024-55660"},"products":["pulse"],"published":"2024-12-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-12-13","vendors":["laravel"]},"summary":"Authenticated users can execute arbitrary code via the unprotected remember method in Laravel Pulse dashboard components.","url":"https://insights.sbomify.com/CVE-2024-55661/"}