# CVE-2024-55661: Laravel Pulse Allows Remote Code Execution via Unprotected Query Method

> Authenticated users can execute arbitrary code via the unprotected remember method in Laravel Pulse dashboard components.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Dec 2024
- **Updated:** 13 Dec 2024
- **Also known as:** GHSA-8vwh-pr89-4mw2

## What is CVE-2024-55661?

CVE-2024-55661 is a high-severity code injection vulnerability in laravel pulse, published on 13 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Laravel Pulse is a real-time application performance monitoring tool and dashboard for Laravel applications. A vulnerability has been discovered in Laravel Pulse prior to version 1.3.1 that could allow remote code execution through the public `remember()` method in the `Laravel\Pulse\Livewire\Concerns\RemembersQueries` trait. This method is accessible via Livewire components and can be exploited to call arbitrary callables within the application. An authenticated user with access to Laravel Pulse dashboard can execute arbitrary code by calling any function or static method in which the callable is a function or static method and the callable has no parameters or no strict parameter types. The vulnerable to component is `remember(callable $query, string $key = '')` method in `Laravel\Pulse\Livewire\Concerns\RemembersQueries`, and the vulnerability affects all Pulse card components that use this trait. Version 1.3.1 contains a patch.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-55661?

2 open source packages ship an affected version, including laravel/pulse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `laravel/pulse` | Packagist | All versions | 1.3.1 |
| `laravel/pulse` | Packagist | All versions | 1.3.1 |

Products: Laravel Pulse.

## How do I fix CVE-2024-55661?

Upgrade laravel/pulse to 1.3.1 or later.

## Is CVE-2024-55661 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55661 exists.

Public exploit code:

- Laravel Pulse 1.3.1 - Arbitrary Code Injection (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-55661 and fix it if it is affected.

What it is: CVE-2024-55661 is a high-severity code injection vulnerability in laravel pulse, published on 13 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55661 exists.

Affected packages and fixed versions:
- laravel/pulse (Packagist): affected all versions; fixed in 1.3.1
- laravel/pulse (Packagist): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-55661/ (Markdown: https://insights.sbomify.com/CVE-2024-55661/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-55661
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-55661
- OSV: https://osv.dev/vulnerability/CVE-2024-55661

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-55661/
Summaries are generated and may contain mistakes; the official description above is the record.
