CVE-2024-55662 XWiki allows remote code execution through the extension sheet
Attackers can execute arbitrary code on XWiki servers if the Extension Repository Application is installed, requiring programming rights.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-55662?
CVE-2024-55662 is a critical code injection vulnerability in Xwiki Xwiki, published on 12 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform. Starting in version 3.3-milestone-1 and prior to versions 15.10.9 and 16.3.0, on instances where `Extension Repository Application` is installed, any user can execute any code requiring `programming` rights on the server. This vulnerability has been fixed in XWiki 15.10.9 and 16.3.0. Since `Extension Repository Application` is not mandatory, it can be safely disabled on instances that do not use it as a workaround. It is also possible to manually apply the patches from commit 8659f17d500522bf33595e402391592a35a162e8 to the page `ExtensionCode.ExtensionSheet` and to the page `ExtensionCode.ExtensionAuthorsDisplayer`.
Which versions are affected by CVE-2024-55662?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-repository-server-ui. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-repository-server-ui Maven | From 16.0.0-rc-1 | 16.3.0 |
org.xwiki.platform:xwiki-platform-repository-server-ui Maven | From 16.0.0-rc-1 | 16.3.0 |
org.xwiki.platform:xwiki-platform-repository-server-ui Maven | From 3.3-milestone-1 | 15.10.9 |
org.xwiki.platform:xwiki-platform-repository-server-ui Maven | From 3.3-milestone-1 | 15.10.9 |
Products include Xwiki Xwiki.
How do I fix CVE-2024-55662?
Upgrade org.xwiki.platform:xwiki-platform-repository-server-ui to a fixed version for your release line: 16.3.0 or 15.10.9.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-55662 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55662 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
- CVE-2024-38369 XWiki programming rights may be inherited by inclusion
Sources
Also known as GHSA-j2pq-22jj-4pm5.