# CVE-2024-55662: XWiki allows remote code execution through the extension sheet

> Attackers can execute arbitrary code on XWiki servers if the Extension Repository Application is installed, requiring programming rights.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2024
- **Updated:** 13 Dec 2024
- **Also known as:** GHSA-j2pq-22jj-4pm5

## What is CVE-2024-55662?

CVE-2024-55662 is a critical code injection vulnerability in Xwiki Xwiki, published on 12 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Starting in version 3.3-milestone-1 and prior to versions 15.10.9 and 16.3.0, on instances where `Extension Repository Application` is installed, any user can execute any code requiring `programming` rights on the server. This vulnerability has been fixed in XWiki 15.10.9 and 16.3.0. Since `Extension Repository Application` is not mandatory, it can be safely disabled on instances that do not use it as a workaround. It is also possible to manually apply the patches from commit 8659f17d500522bf33595e402391592a35a162e8 to the page `ExtensionCode.ExtensionSheet` and to the page `ExtensionCode.ExtensionAuthorsDisplayer`.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-96 (Improper Neutralization of Directives in Statically Saved Code), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-55662?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-repository-server-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-repository-server-ui` | Maven | From 16.0.0-rc-1 | 16.3.0 |
| `org.xwiki.platform:xwiki-platform-repository-server-ui` | Maven | From 16.0.0-rc-1 | 16.3.0 |
| `org.xwiki.platform:xwiki-platform-repository-server-ui` | Maven | From 3.3-milestone-1 | 15.10.9 |
| `org.xwiki.platform:xwiki-platform-repository-server-ui` | Maven | From 3.3-milestone-1 | 15.10.9 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-55662?

Upgrade org.xwiki.platform:xwiki-platform-repository-server-ui to a fixed version for your release line: 16.3.0 or 15.10.9.

## Is CVE-2024-55662 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55662 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)
- [CVE-2024-38369](https://insights.sbomify.com/CVE-2024-38369/): XWiki programming rights may be inherited by inclusion (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-55662 and fix it if it is affected.

What it is: CVE-2024-55662 is a critical code injection vulnerability in Xwiki Xwiki, published on 12 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55662 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-repository-server-ui (Maven): affected from 16.0.0-rc-1; fixed in 16.3.0
- org.xwiki.platform:xwiki-platform-repository-server-ui (Maven): affected from 16.0.0-rc-1; fixed in 16.3.0
- org.xwiki.platform:xwiki-platform-repository-server-ui (Maven): affected from 3.3-milestone-1; fixed in 15.10.9
- org.xwiki.platform:xwiki-platform-repository-server-ui (Maven): affected from 3.3-milestone-1; fixed in 15.10.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-55662/ (Markdown: https://insights.sbomify.com/CVE-2024-55662/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-55662
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-55662
- OSV: https://osv.dev/vulnerability/CVE-2024-55662

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-55662/
Summaries are generated and may contain mistakes; the official description above is the record.
