# CVE-2024-55663: XWiki Platform has an SQL injection in getdocuments.vm with sort parameter

> Attackers can inject HQL via the sort parameter to read sensitive data or modify database contents in XWiki Platform.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2024
- **Updated:** 16 Dec 2024
- **Also known as:** GHSA-wh34-m772-5398

## What is CVE-2024-55663?

CVE-2024-55663 is a high-severity SQL injection vulnerability in Xwiki Xwiki, published on 12 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Starting in version 6.3-milestone-2 and prior to versions 13.10.5 and 14.3-rc-1, in `getdocument.vm`; the ordering of the returned documents is defined from an unsanitized request parameter (request.sort) and can allow any user to inject HQL. Depending on the used database backend, the attacker may be able to not only obtain confidential information such as password hashes from the database, but also execute UPDATE/INSERT/DELETE queries. This has been patched in 13.10.5 and 14.3-rc-1. There is no known workaround, other than upgrading XWiki.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2024-55663?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-distribution-war. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 14.0-rc-1 | 14.3-rc-1 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 14.0-rc-1 | 14.3-rc-1 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 6.3-milestone-2 | 13.10.5 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 6.3-milestone-2 | 13.10.5 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-55663?

Upgrade org.xwiki.platform:xwiki-platform-distribution-war to a fixed version for your release line: 14.3-rc-1 or 13.10.5.

## Is CVE-2024-55663 being exploited?

There is no known exploitation of CVE-2024-55663 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-55663 and fix it if it is affected.

What it is: CVE-2024-55663 is a high-severity SQL injection vulnerability in Xwiki Xwiki, published on 12 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-55663 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 14.0-rc-1; fixed in 14.3-rc-1
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 14.0-rc-1; fixed in 14.3-rc-1
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 6.3-milestone-2; fixed in 13.10.5
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 6.3-milestone-2; fixed in 13.10.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-55663/ (Markdown: https://insights.sbomify.com/CVE-2024-55663/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-55663
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-55663
- OSV: https://osv.dev/vulnerability/CVE-2024-55663

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-55663/
Summaries are generated and may contain mistakes; the official description above is the record.
