# CVE-2024-5569: Denial of Service via crafted zip file in jaraco/zipp

> Attackers can cause a denial of service via infinite loop in jaraco/zipp and CPython zipfile when processing crafted zip files.

- **Severity:** Medium 6.2 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2024
- **Updated:** 15 Oct 2025
- **Also known as:** AZL-43189, AZL-43198, DEBIAN-CVE-2024-5569, ECHO-1d97-bd5e-f1bb, GHSA-jfmj-5v4g-7637, MGASA-2025-0066, OESA-2024-1887, OESA-2024-1888, OESA-2024-1889, OESA-2024-1890, PYSEC-2026-2074, RHSA-2024:9977, ROOT-APP-PYPI-CVE-2024-5569, SUSE-SU-2024:2397-1, SUSE-SU-2024:2400-1, UBUNTU-CVE-2024-5569, USN-6906-1, openSUSE-SU-2024:14167-1, openSUSE-SU-2026:12048-1

## What is CVE-2024-5569?

CVE-2024-5569 is a medium-severity denial of service vulnerability in jaraco/zipp, published on 9 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A Denial of Service (DoS) vulnerability exists in the jaraco/zipp library, affecting all versions prior to 3.19.1. The vulnerability is triggered when processing a specially crafted zip file that leads to an infinite loop. This issue also impacts the zipfile module of CPython, as features from the third-party zipp library are later merged into CPython, and the affected code is identical in both projects. The infinite loop can be initiated through the use of functions affecting the `Path` module in both zipp and zipfile, such as `joinpath`, the overloaded division operator, and `iterdir`. Although the infinite loop is not resource exhaustive, it prevents the application from responding. The vulnerability was addressed in version 3.19.1 of jaraco/zipp.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2024-5569?

3 open source packages ship an affected version, including zipp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zipp` | PyPI | All versions | 3.19.1 |
| `zipp` | PyPI | All versions | 3.19.1 |
| `zipp` | PyPI | All versions | 3.19.1 |
| `python-zipp` | Red Hat:openstack:17.1::el9 | All versions | 0:3.4.0-3.el9ost |
| `python3-zipp` | Red Hat:openstack:17.1::el9 | All versions | 0:3.4.0-3.el9ost |
| `python-zipp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 3.15.0-150400.10.10.1 |
| `python-zipp` | SUSE:Linux Enterprise Module for Python 3 15 SP5 | All versions | 3.15.0-150400.10.10.1 |
| `python-zipp` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 3.17.0-150600.3.3.1 |
| `python-zipp` | openSUSE:Leap 15.5 | All versions | 3.15.0-150400.10.10.1 |
| `python-zipp` | openSUSE:Leap 15.6 | All versions | 3.15.0-150400.10.10.1 |
| `python-zipp` | openSUSE:Leap 15.6 | All versions | 3.17.0-150600.3.3.1 |
| `python-zipp` | openSUSE:Tumbleweed | All versions | 3.19.2-2.1 |
| `python-zipp` | openSUSE:Tumbleweed | All versions | 4.1.0-1.2 |

## How do I fix CVE-2024-5569?

Upgrade zipp to 3.19.1 or later.

## Is CVE-2024-5569 being exploited?

There is no known exploitation of CVE-2024-5569 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5569 and fix it if it is affected.

What it is: CVE-2024-5569 is a medium-severity denial of service vulnerability in jaraco/zipp, published on 9 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-5569 in the wild and no public exploit code.

Affected packages and fixed versions:
- zipp (PyPI): affected all versions; fixed in 3.19.1
- zipp (PyPI): affected all versions; fixed in 3.19.1
- zipp (PyPI): affected all versions; fixed in 3.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5569/ (Markdown: https://insights.sbomify.com/CVE-2024-5569/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5569
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5569
- OSV: https://osv.dev/vulnerability/CVE-2024-5569

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5569/
Summaries are generated and may contain mistakes; the official description above is the record.
