# CVE-2024-5585: Command injection via array-ish $command parameter of proc_open() (bypass CVE-2024-1874 fix)

> Attackers can execute arbitrary commands on Windows systems via proc_open() if they control command arguments, bypassing previous security fixes.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2024
- **Updated:** 13 Feb 2025
- **Also known as:** AZL-42427, AZL-42439, BIT-libphp-2024-5585, BIT-php-2024-5585, BIT-php-min-2024-5585, GHSA-9fcc-425m-g385

## What is CVE-2024-5585?

CVE-2024-5585 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 9 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 8.1.* before 8.1.29, 8.2.* before 8.2.20, 8.3.* before 8.3.8, the fix for CVE-2024-1874 does not work if the command name includes trailing spaces. Original issue: when using proc_open() command with array syntax, due to insufficient escaping, if the arguments of the executed command are controlled by a malicious user, the user can supply arguments that would execute arbitrary commands in Windows shell.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2024-5585?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.29, 8.2.20, 8.3.8 |
| `php` | Bitnami | All versions | 8.1.29, 8.2.20, 8.3.8 |
| `php-min` | Bitnami | All versions | 8.1.29, 8.2.20, 8.3.8 |

Products: Fedoraproject Fedora, Php Php.

## How do I fix CVE-2024-5585?

Upgrade libphp to a fixed version for your release line: 8.1.29, 8.2.20 or 8.3.8.

## Is CVE-2024-5585 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5585 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5585 and fix it if it is affected.

What it is: CVE-2024-5585 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 9 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5585 exists.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.29, 8.2.20, 8.3.8
- php (Bitnami): affected all versions; fixed in 8.1.29, 8.2.20, 8.3.8
- php-min (Bitnami): affected all versions; fixed in 8.1.29, 8.2.20, 8.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5585/ (Markdown: https://insights.sbomify.com/CVE-2024-5585/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5585
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5585
- OSV: https://osv.dev/vulnerability/CVE-2024-5585

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5585/
Summaries are generated and may contain mistakes; the official description above is the record.
