CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList

Critical 10.0 Published Updated

Authenticated users can execute arbitrary code via macro descriptions, compromising the entire XWiki installation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-55877?

CVE-2024-55877 is a critical code injection vulnerability in Xwiki Xwiki, published on 12 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

XWiki Platform is a generic wiki platform. Starting in version 9.7-rc-1 and prior to versions 15.10.11, 16.4.1, and 16.5.0, any user with an account can perform arbitrary remote code execution by adding instances of `XWiki.WikiMacroClass` to any page. This compromises the confidentiality, integrity and availability of the whole XWiki installation. This vulnerability has been fixed in XWiki 15.10.11, 16.4.1 and 16.5.0. It is possible to manually apply the patch to the page `XWiki.XWikiSyntaxMacrosList` as a workaround.

Weakness: CWE-94, CWE-96

Which versions are affected by CVE-2024-55877?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-help-ui. It affects 1 product.

PackageAffectedFixed in
org.xwiki.platform:xwiki-platform-help-ui MavenFrom 16.0.0-rc-116.4.1
org.xwiki.platform:xwiki-platform-help-ui MavenFrom 16.0.0-rc-116.4.1
org.xwiki.platform:xwiki-platform-help-ui MavenFrom 16.5.0-rc-116.5.0
org.xwiki.platform:xwiki-platform-help-ui MavenFrom 16.5.0-rc-116.5.0
org.xwiki.platform:xwiki-platform-help-ui MavenFrom 9.7-rc-115.10.11
org.xwiki.platform:xwiki-platform-help-ui MavenFrom 9.7-rc-115.10.11

Products include Xwiki Xwiki.

How do I fix CVE-2024-55877?

Upgrade org.xwiki.platform:xwiki-platform-help-ui to a fixed version for your release line: 16.4.1, 16.5.0 or 15.10.11.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-55877 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55877 exists.

All Xwiki Xwiki vulnerabilities

Sources

Also known as GHSA-2r87-74cx-2p7c.

Is CVE-2024-55877 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free