# CVE-2024-55878: Cross-site Scripting vulnerability in SimpleXLSXEx::readXfs and SimpeXLSX::toHTMLEx


- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 12 Dec 2024
- **Updated:** 13 Dec 2024
- **Also known as:** GHSA-x6mh-rjwm-8ph7

## What is CVE-2024-55878?

CVE-2024-55878 is a medium-severity vulnerability in shuchkin simplexlsx, published on 12 Dec 2024. 

### Official description

SimpleXLSX is software for parsing and retrieving data from Excel XLSx files. Starting in version 1.0.12 and prior to version 1.1.12, when calling the extended toHTMLEx method, it is possible to execute arbitrary JavaScript code. Version 1.1.12 fixes the issue. As a workaround, don't use direct publication via toHTMLEx.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-55878?

2 open source packages ship an affected version, including shuchkin/simplexlsx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shuchkin/simplexlsx` | Packagist | From 1.0.12 | 1.1.12 |
| `shuchkin/simplexlsx` | Packagist | From 1.0.12 | 1.1.12 |

## How do I fix CVE-2024-55878?

Upgrade shuchkin/simplexlsx to 1.1.12 or later.

## Is CVE-2024-55878 being exploited?

There is no known exploitation of CVE-2024-55878 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-55878 and fix it if it is affected.

What it is: CVE-2024-55878 is a medium-severity vulnerability in shuchkin simplexlsx, published on 12 Dec 2024. 
Exploitation: There is no known exploitation of CVE-2024-55878 in the wild and no public exploit code.

Affected packages and fixed versions:
- shuchkin/simplexlsx (Packagist): affected from 1.0.12; fixed in 1.1.12
- shuchkin/simplexlsx (Packagist): affected from 1.0.12; fixed in 1.1.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-55878/ (Markdown: https://insights.sbomify.com/CVE-2024-55878/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-55878
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-55878
- OSV: https://osv.dev/vulnerability/CVE-2024-55878

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-55878/
Summaries are generated and may contain mistakes; the official description above is the record.
