CVE-2024-55879 XWiki allows RCE from script right in configurable sections
Users with script rights can execute arbitrary code via configurable sections, compromising the entire XWiki installation.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-55879?
CVE-2024-55879 is a critical code injection vulnerability in Xwiki Xwiki, published on 12 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform. Starting in version 2.3 and prior to versions 15.10.9, 16.3.0, any user with script rights can perform arbitrary remote code execution by adding instances of `XWiki.ConfigurableClass` to any page. This compromises the confidentiality, integrity and availability of the whole XWiki installation. This has been patched in XWiki 15.10.9 and 16.3.0. No known workarounds are available except upgrading.
Weakness: CWE-862
Which versions are affected by CVE-2024-55879?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-administration-ui. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-administration-ui Maven | From 16.0.0-rc-1 | 16.3.0 |
org.xwiki.platform:xwiki-platform-administration-ui Maven | From 16.0.0-rc-1 | 16.3.0 |
org.xwiki.platform:xwiki-platform-administration-ui Maven | From 2.3 | 15.10.9 |
org.xwiki.platform:xwiki-platform-administration-ui Maven | From 2.3 | 15.10.9 |
Products include Xwiki Xwiki.
How do I fix CVE-2024-55879?
Upgrade org.xwiki.platform:xwiki-platform-administration-ui to a fixed version for your release line: 16.3.0 or 15.10.9.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-55879 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55879 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-r279-47wg-chpr.