# CVE-2024-55879: XWiki allows RCE from script right in configurable sections

> Users with script rights can execute arbitrary code via configurable sections, compromising the entire XWiki installation.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2024
- **Updated:** 13 Dec 2024
- **Also known as:** GHSA-r279-47wg-chpr

## What is CVE-2024-55879?

CVE-2024-55879 is a critical code injection vulnerability in Xwiki Xwiki, published on 12 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Starting in version 2.3 and prior to versions 15.10.9, 16.3.0, any user with script rights can perform arbitrary remote code execution by adding instances of `XWiki.ConfigurableClass` to any page. This compromises the confidentiality, integrity and availability of the whole XWiki installation. This has been patched in XWiki 15.10.9 and 16.3.0. No known workarounds are available except upgrading.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-55879?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-administration-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 16.0.0-rc-1 | 16.3.0 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 16.0.0-rc-1 | 16.3.0 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 2.3 | 15.10.9 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 2.3 | 15.10.9 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-55879?

Upgrade org.xwiki.platform:xwiki-platform-administration-ui to a fixed version for your release line: 16.3.0 or 15.10.9.

## Is CVE-2024-55879 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55879 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-55879 and fix it if it is affected.

What it is: CVE-2024-55879 is a critical code injection vulnerability in Xwiki Xwiki, published on 12 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55879 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 16.0.0-rc-1; fixed in 16.3.0
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 16.0.0-rc-1; fixed in 16.3.0
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 2.3; fixed in 15.10.9
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 2.3; fixed in 15.10.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-55879/ (Markdown: https://insights.sbomify.com/CVE-2024-55879/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-55879
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-55879
- OSV: https://osv.dev/vulnerability/CVE-2024-55879

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-55879/
Summaries are generated and may contain mistakes; the official description above is the record.
