{"answers":{"affected":"2 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55889 exists.","fix":"Upgrade thorsten/phpmyfaq to 3.2.10 or later.","what":"CVE-2024-55889 is a medium-severity vulnerability in Phpmyfaq Phpmyfaq, published on 13 Dec 2024."},"fix_prompt":"Check this codebase for CVE-2024-55889 and fix it if it is affected.\n\nWhat it is: CVE-2024-55889 is a medium-severity vulnerability in Phpmyfaq Phpmyfaq, published on 13 Dec 2024. \nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55889 exists.\n\nAffected packages and fixed versions:\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 3.2.10\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 3.2.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-55889/ (Markdown: https://insights.sbomify.com/CVE-2024-55889/index.md)","id":"CVE-2024-55889","markdown":"https://insights.sbomify.com/CVE-2024-55889/index.md","name":"CVE-2024-55889","record":{"aliases":["GHSA-m3r7-8gw7-qwvc"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-451","name":"User Interface (UI) Misrepresentation of Critical Information"}],"description":"phpMyFAQ is an open source FAQ web application. Prior to version 3.2.10, a vulnerability exists in the FAQ Record component where a privileged attacker can trigger a file download on a victim's machine upon page visit by embedding it in an \u003ciframe\u003e element without user interaction or explicit consent. Version 3.2.10 fixes the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2025-04-16","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-04-16","kind":"exploitdb","ref":"52235","stars":null,"title":"phpMyFAQ 3.2.10 - Unintended File Download Triggered by Embedded Frames"}],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ Vulnerable to Unintended File Download Triggered by Embedded Frames","id":"CVE-2024-55889","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":null,"year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"D-Tale allows Remote Code Execution through the Custom Filter Input","id":"CVE-2024-55890"},"packages":[{"ecosystem":"Packagist","fixed":["3.2.10"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-m3r7-8gw7-qwvc"},{"ecosystem":"Packagist","fixed":["3.2.10"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-m3r7-8gw7-qwvc"}],"prev":{"headline":"Content Security Policy appears to be missing in software and production setup","id":"CVE-2024-55888"},"products":["phpMyFAQ"],"published":"2024-12-13","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-13","vendors":["thorsten"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-55889/"}