# CVE-2024-55889: phpMyFAQ Vulnerable to Unintended File Download Triggered by Embedded Frames


- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 Dec 2024
- **Updated:** 13 Dec 2024
- **Also known as:** GHSA-m3r7-8gw7-qwvc

## What is CVE-2024-55889?

CVE-2024-55889 is a medium-severity vulnerability in Phpmyfaq Phpmyfaq, published on 13 Dec 2024. 

### Official description

phpMyFAQ is an open source FAQ web application. Prior to version 3.2.10, a vulnerability exists in the FAQ Record component where a privileged attacker can trigger a file download on a victim's machine upon page visit by embedding it in an <iframe> element without user interaction or explicit consent. Version 3.2.10 fixes the issue.

Weakness: CWE-451 (User Interface (UI) Misrepresentation of Critical Information)

## Which versions are affected by CVE-2024-55889?

2 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | All versions | 3.2.10 |
| `thorsten/phpmyfaq` | Packagist | All versions | 3.2.10 |

Products: Phpmyfaq Phpmyfaq.

## How do I fix CVE-2024-55889?

Upgrade thorsten/phpmyfaq to 3.2.10 or later.

## Is CVE-2024-55889 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55889 exists.

Public exploit code:

- phpMyFAQ 3.2.10 - Unintended File Download Triggered by Embedded Frames (exploitdb)

## Other vulnerabilities in Phpmyfaq Phpmyfaq

- [CVE-2023-0310](https://insights.sbomify.com/CVE-2023-0310/): Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq (critical 9.8)
- [CVE-2022-4407](https://insights.sbomify.com/CVE-2022-4407/): Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq (critical 9.8)
- [CVE-2017-11187](https://insights.sbomify.com/CVE-2017-11187/): Security feature bypass in n/a (critical 9.8)
- [CVE-2026-76213](https://insights.sbomify.com/CVE-2026-76213/): phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle (critical 9.1)
- [CVE-2026-76214](https://insights.sbomify.com/CVE-2026-76214/): phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-55889 and fix it if it is affected.

What it is: CVE-2024-55889 is a medium-severity vulnerability in Phpmyfaq Phpmyfaq, published on 13 Dec 2024. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55889 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 3.2.10
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 3.2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-55889/ (Markdown: https://insights.sbomify.com/CVE-2024-55889/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-55889
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-55889
- OSV: https://osv.dev/vulnerability/CVE-2024-55889

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-55889/
Summaries are generated and may contain mistakes; the official description above is the record.
