{"answers":{"affected":"3 open source packages ship an affected version, including dtale.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55890 exists.","fix":"Upgrade dtale to 3.16.1 or later.","what":"CVE-2024-55890 is a medium-severity code injection vulnerability in man-group dtale, published on 13 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-55890 and fix it if it is affected.\n\nWhat it is: CVE-2024-55890 is a medium-severity code injection vulnerability in man-group dtale, published on 13 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55890 exists.\n\nAffected packages and fixed versions:\n- dtale (PyPI): affected all versions; fixed in 3.16.1\n- dtale (PyPI): affected all versions; fixed in 3.16.1\n- dtale (PyPI): affected all versions; fixed in 3.16.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-55890/ (Markdown: https://insights.sbomify.com/CVE-2024-55890/index.md)","id":"CVE-2024-55890","markdown":"https://insights.sbomify.com/CVE-2024-55890/index.md","name":"CVE-2024-55890","record":{"aliases":["CVE-2025-0655","GHSA-832w-fhmw-w4f4","PYSEC-2026-1320"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"D-Tale visualizer","requires_auth":"none","summary":"Attackers can execute arbitrary code on servers hosting D-Tale if custom filters are enabled, requiring an upgrade to secure the application.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"D-Tale is a visualizer for pandas data structures. Prior to version 3.16.1, users hosting D-Tale publicly can be vulnerable to remote code execution allowing attackers to run malicious code on the server. Users should upgrade to version 3.16.1 where the `update-settings` endpoint blocks the ability for users to update the `enable_custom_filters` flag. The only workaround for versions earlier than 3.16.1 is to only host D-Tale to trusted users.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2025-06-13","github_poc":2,"max_poc_stars":0,"metasploit":0,"nuclei":1,"refs":[{"date":"2025-06-13T04:26:01Z","kind":"github_poc","ref":"https://github.com/samh4cks/CVE-2024-55890","stars":0,"title":null},{"date":"2026-08-24T03:05:23Z","kind":"github_poc","ref":"https://github.com/gduma-phData/patch-CVE-2024-55890","stars":0,"title":"Patch: Sandbox escape (macOS Kernel)"},{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-55890.yaml","stars":null,"title":"D-Tale \u003c= 3.16.0 - Pre-Auth RCE via Pandas Query Injection"}],"tier":"weaponised"},"has_fix":true,"headline":"D-Tale allows Remote Code Execution through the Custom Filter Input","id":"CVE-2024-55890","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Information Disclosure via Exception Handling/Logger in TYPO3","id":"CVE-2024-55891"},"packages":[{"ecosystem":"PyPI","fixed":["3.16.1"],"introduced":["0"],"last_affected":[],"package":"dtale","purl":null,"source":"GHSA-832w-fhmw-w4f4"},{"ecosystem":"PyPI","fixed":["3.16.1"],"introduced":["0"],"last_affected":[],"package":"dtale","purl":"pkg:pypi/dtale","source":"GHSA-832w-fhmw-w4f4"},{"ecosystem":"PyPI","fixed":["3.16.1"],"introduced":["0"],"last_affected":[],"package":"dtale","purl":"pkg:pypi/dtale","source":"PYSEC-2026-1320"}],"prev":{"headline":"phpMyFAQ Vulnerable to Unintended File Download Triggered by Embedded Frames","id":"CVE-2024-55889"},"products":["dtale"],"published":"2024-12-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-13","vendors":["man-group"]},"summary":"Attackers can execute arbitrary code on servers hosting D-Tale if custom filters are enabled, requiring an upgrade to secure the application.","url":"https://insights.sbomify.com/CVE-2024-55890/"}