# CVE-2024-55924: Cross-Site Request Forgery in Scheduler Module in TYPO3

> Attackers can trigger unauthorized data import or export via CSRF in the TYPO3 Scheduler Module if specific security settings are misconfigured.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jan 2025
- **Updated:** 15 Jan 2025
- **Also known as:** GHSA-7835-fcv3-g256

## What is CVE-2024-55924?

CVE-2024-55924 is a high-severity vulnerability in Typo3 Typo3, published on 14 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

TYPO3 is a free and open source Content Management Framework. A vulnerability has been identified in the backend user interface functionality involving deep links. Specifically, this functionality is susceptible to Cross-Site Request Forgery (CSRF). Additionally, state-changing actions in downstream components incorrectly accepted submissions via HTTP GET and did not enforce the appropriate HTTP method. Successful exploitation of this vulnerability requires the victim to have an active session on the backend user interface and to be deceived into interacting with a malicious URL targeting the backend, which can occur under the following conditions: The user opens a malicious link, such as one sent via email. The user visits a compromised or manipulated website while the following settings are misconfigured: 1. `security.backend.enforceReferrer` feature is disabled, 2. `BE/cookieSameSite` configuration is set to lax or none. The vulnerability in the affected downstream component “Scheduler Module” allows attackers to trigger pre-defined command classes - which can lead to unauthorized import or export of data in the worst case. Users are advised to update to TYPO3 versions 11.5.42 ELTS which fixes the problem described. There are no known workarounds for this vulnerability.

Weakness: CWE-749 (Exposed Dangerous Method or Function), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-55924?

2 open source packages ship an affected version, including typo3/cms-scheduler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-scheduler` | Packagist | From 11.0.0 | 11.5.42 |
| `typo3/cms-scheduler` | Packagist | From 11.0.0 | 11.5.42 |

Products: Typo3 Typo3.

## How do I fix CVE-2024-55924?

Upgrade typo3/cms-scheduler to 11.5.42 or later.

## Is CVE-2024-55924 being exploited?

There is no known exploitation of CVE-2024-55924 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-55924 and fix it if it is affected.

What it is: CVE-2024-55924 is a high-severity vulnerability in Typo3 Typo3, published on 14 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-55924 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-scheduler (Packagist): affected from 11.0.0; fixed in 11.5.42
- typo3/cms-scheduler (Packagist): affected from 11.0.0; fixed in 11.5.42

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-55924/ (Markdown: https://insights.sbomify.com/CVE-2024-55924/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-55924
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-55924
- OSV: https://osv.dev/vulnerability/CVE-2024-55924

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-55924/
Summaries are generated and may contain mistakes; the official description above is the record.
