CVE-2024-55945 Cross-Site Request Forgery in DB Check Module in TYPO3

Medium 4.3 Published Updated

Attackers can manipulate data via CSRF in the DB Check Module if specific security settings are disabled or misconfigured.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-55945?

CVE-2024-55945 is a medium-severity vulnerability in Typo3 Typo3, published on 14 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

TYPO3 is a free and open source Content Management Framework. A vulnerability has been identified in the backend user interface functionality involving deep links. Specifically, this functionality is susceptible to Cross-Site Request Forgery (CSRF). Additionally, state-changing actions in downstream components incorrectly accepted submissions via HTTP GET and did not enforce the appropriate HTTP method. Successful exploitation of this vulnerability requires the victim to have an active session on the backend user interface and to be deceived into interacting with a malicious URL targeting the backend, which can occur under the following conditions: The user opens a malicious link, such as one sent via email. The user visits a compromised or manipulated website while the following settings are misconfigured: 1. `security.backend.enforceReferrer` feature is disabled, 2. `BE/cookieSameSite` configuration is set to `lax` or `none`. The vulnerability in the affected downstream component “DB Check Module” allows attackers to manipulate data through unauthorized actions. Users are advised to update to TYPO3 versions 11.5.42 ELTS which fixes the problem described. There are no known workarounds for this issue.

Weakness: CWE-749, CWE-352

Which versions are affected by CVE-2024-55945?

2 open source packages ship an affected version, including typo3/cms-lowlevel. It affects 1 product.

PackageAffectedFixed in
typo3/cms-lowlevel PackagistFrom 11.0.011.5.42
typo3/cms-lowlevel PackagistFrom 11.0.011.5.42

Products include Typo3 Typo3.

How do I fix CVE-2024-55945?

Upgrade typo3/cms-lowlevel to 11.5.42 or later.

Is CVE-2024-55945 being exploited?

There is no known exploitation of CVE-2024-55945 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-8mv3-37rc-pvxj.

Is CVE-2024-55945 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free