# CVE-2024-55950: Tabby has a TCC Bypass via Unnecessary Permissive Entitlements in Tabby

> Tabby terminal emulator allows code injection via DYLD_INSERT_LIBRARIES due to overly permissive macOS entitlements, enabling attackers to bypass security controls.

- **Severity:** High 8.6 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Dec 2024
- **Updated:** 27 Dec 2024
- **Also known as:** GHSA-jx33-9jc7-24gc

## What is CVE-2024-55950?

CVE-2024-55950 is a high-severity vulnerability in Eugeny tabby, published on 26 Dec 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Tabby (formerly Terminus) is a highly configurable terminal emulator. Prior to 1.0.216, Tabby terminal emulator contains overly permissive entitlements that are unnecessary for its core functionality and plugin system, creating potential security vulnerabilities. The application currently holds powerful permissions including camera, microphone access, and the ability to access personal folders (Downloads, Documents, etc.) through Apple Events, while also maintaining dangerous entitlements that enable code injection. The concerning entitlements are com.apple.security.cs.allow-dyld-environment-variables and com.apple.security.cs.disable-library-validation. Since Tabby's plugins and themes are NodeJS-based without native libraries or frameworks, and no environment variables are used in the codebase, it is recommended to review and remove at least one of the entitlements (com.apple.security.cs.disable-library-validation or com.apple.security.cs.allow-dyld-environment-variables) to prevent DYLD_INSERT_LIBRARIES injection while maintaining full application functionality. This vulnerability is fixed in 1.0.216.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2024-55950?


## How do I fix CVE-2024-55950?

No fix has been published for CVE-2024-55950 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-55950 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55950 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-55950 and fix it if it is affected.

What it is: CVE-2024-55950 is a high-severity vulnerability in Eugeny tabby, published on 26 Dec 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-55950 exists.

Affected product: Eugeny tabby. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-55950/ (Markdown: https://insights.sbomify.com/CVE-2024-55950/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-55950
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-55950
- OSV: https://osv.dev/vulnerability/CVE-2024-55950

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-55950/
Summaries are generated and may contain mistakes; the official description above is the record.
