CVE-2024-55958 Cross-site scripting in n/a
Cross-site scripting vulnerability in CFEngine Enterprise Mission Portal allows attackers to execute arbitrary scripts in user browsers.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2024-55958?
CVE-2024-55958 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Jan 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Northern.tech CFEngine Enterprise Mission Portal 3.24.0, 3.21.5, and below allows XSS. The fixed versions are 3.24.1 and 3.21.6.
Weakness: CWE-79
Which versions are affected by CVE-2024-55958?
How do I fix CVE-2024-55958?
No fix has been published for CVE-2024-55958 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-55958 being exploited?
There is no known exploitation of CVE-2024-55958 in the wild and no public exploit code.
Sources
Also known as GHSA-chj5-7hc4-jvpw.