# CVE-2024-56137: MaxKB RCE vulnerability in function library

> Privileged users can execute arbitrary OS commands via custom scripts in the function library module of MaxKB.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 2 Jan 2025
- **Updated:** 2 Jan 2025
- **Also known as:** GHSA-76w2-2g72-cg85

## What is CVE-2024-56137?

CVE-2024-56137 is a medium-severity command injection vulnerability in 1Panel-dev MaxKB, published on 2 Jan 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

MaxKB, which stands for Max Knowledge Base, is an open source knowledge base question-answering system based on a large language model and retrieval-augmented generation (RAG). Prior to version 1.9.0, a remote command execution vulnerability exists in the module of function library. The vulnerability allow privileged‌ users to execute OS command in custom scripts. The vulnerability has been fixed in v1.9.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2024-56137?

It affects 1 product.


Products: Maxkb Maxkb.

## How do I fix CVE-2024-56137?

No fix has been published for CVE-2024-56137 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-56137 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56137 exists.

## Other vulnerabilities in 1Panel-dev MaxKB

- [CVE-2025-66419](https://insights.sbomify.com/CVE-2025-66419/): MaxKB vulnerable to privilege escalation through sandbox bypass (high 8.8)
- [CVE-2025-66446](https://insights.sbomify.com/CVE-2025-66446/): MaxKB has a Python sandbox LD_PRELOAD bypass (high 8.8)
- [CVE-2025-64511](https://insights.sbomify.com/CVE-2025-64511/): MaxKB has SSRF in sandbox (high 7.4)
- [CVE-2026-39422](https://insights.sbomify.com/CVE-2026-39422/): MaxKB has Stored XSS via ChatHeadersMiddleware (medium 6.9)
- [CVE-2026-39423](https://insights.sbomify.com/CVE-2026-39423/): Stored XSS via Eval Injection in EchartsRander Component (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56137 and fix it if it is affected.

What it is: CVE-2024-56137 is a medium-severity command injection vulnerability in 1Panel-dev MaxKB, published on 2 Jan 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56137 exists.

Affected product: 1Panel-dev MaxKB. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56137/ (Markdown: https://insights.sbomify.com/CVE-2024-56137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56137
- OSV: https://osv.dev/vulnerability/CVE-2024-56137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56137/
Summaries are generated and may contain mistakes; the official description above is the record.
