# CVE-2024-56143: Strapi Allows Unauthorized Access to Private Fields via parms.lookup

> Attackers can access sensitive private fields like admin passwords by exploiting unsanitized lookup parameters in Strapi queries.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2025
- **Updated:** 16 Oct 2025
- **Also known as:** GHSA-495j-h493-42q2

## What is CVE-2024-56143?

CVE-2024-56143 is a high-severity missing authorization vulnerability in strapi, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Strapi is an open-source headless content management system. In versions from 5.0.0 to before 5.5.2, the lookup operator provided by the document service does not properly sanitize query parameters for private fields. An attacker can access private fields, including admin passwords and reset tokens, by crafting queries with the lookup parameter. This vulnerability is fixed in 5.5.2.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2024-56143?

2 open source packages ship an affected version, including @strapi/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/core` | npm | From 5.0.0 | 5.5.2 |
| `@strapi/core` | npm | From 5.0.0 | 5.5.2 |

Products: Strapi Strapi.

## How do I fix CVE-2024-56143?

Upgrade @strapi/core to 5.5.2 or later.

## Is CVE-2024-56143 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56143 exists.

## Other vulnerabilities in strapi

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56143 and fix it if it is affected.

What it is: CVE-2024-56143 is a high-severity missing authorization vulnerability in strapi, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56143 exists.

Affected packages and fixed versions:
- @strapi/core (npm): affected from 5.0.0; fixed in 5.5.2
- @strapi/core (npm): affected from 5.0.0; fixed in 5.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56143/ (Markdown: https://insights.sbomify.com/CVE-2024-56143/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56143
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56143
- OSV: https://osv.dev/vulnerability/CVE-2024-56143

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56143/
Summaries are generated and may contain mistakes; the official description above is the record.
