# CVE-2024-56144: Stored XSS-LibreNMS-Display Name 2 in librenms

> Attackers can inject malicious scripts via the display name parameter, leading to script execution when viewed by other users.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-2f4w-6mc7-4w78

## What is CVE-2024-56144?

CVE-2024-56144 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 16 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

librenms is a community-based GPL-licensed network monitoring system. Affected versions are subject to a stored XSS on the parameters (Replace $DEVICE_ID with your specific $DEVICE_ID value):`/device/$DEVICE_ID/edit` -> param: display. Librenms versions up to 24.11.0 allow remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. This issue has been addressed in release version 24.12.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-56144?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | From 24.11.10 | 24.12.0 |
| `librenms/librenms` | Packagist | From 24.11.10 | 24.12.0 |

Products: Librenms Librenms.

## How do I fix CVE-2024-56144?

Upgrade librenms/librenms to 24.12.0 or later.

## Is CVE-2024-56144 being exploited?

There is no known exploitation of CVE-2024-56144 in the wild and no public exploit code.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56144 and fix it if it is affected.

What it is: CVE-2024-56144 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 16 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-56144 in the wild and no public exploit code.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected from 24.11.10; fixed in 24.12.0
- librenms/librenms (Packagist): affected from 24.11.10; fixed in 24.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56144/ (Markdown: https://insights.sbomify.com/CVE-2024-56144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56144
- OSV: https://osv.dev/vulnerability/CVE-2024-56144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56144/
Summaries are generated and may contain mistakes; the official description above is the record.
