# CVE-2024-56158: XWiki allows SQL injection in query endpoint of REST API with Oracle

> Attackers can execute arbitrary SQL queries via the REST API when using Oracle, allowing data access or modification.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2025
- **Updated:** 12 Jan 2026
- **Also known as:** GHSA-prwh-7838-xf82

## What is CVE-2024-56158?

CVE-2024-56158 is a critical SQL injection vulnerability in Xwiki Xwiki, published on 12 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki is a generic wiki platform. It's possible to execute any SQL query in Oracle by using the function like DBMS_XMLGEN or DBMS_XMLQUERY. The XWiki query validator does not sanitize functions that would be used in a simple select and Hibernate allows using any native function in an HQL query. This vulnerability is fixed in 16.10.2, 16.4.7, and 15.10.16.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-56158?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.0 | 15.10.16 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.0 | 15.10.16 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.0.0-rc-1 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.0.0-rc-1 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.2 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.2 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-56158?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.10.16, 16.4.7 or 16.10.2.

## Is CVE-2024-56158 being exploited?

There is no known exploitation of CVE-2024-56158 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56158 and fix it if it is affected.

What it is: CVE-2024-56158 is a critical SQL injection vulnerability in Xwiki Xwiki, published on 12 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56158 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.0; fixed in 15.10.16
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.0; fixed in 15.10.16
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.0.0-rc-1; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.0.0-rc-1; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.2
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56158/ (Markdown: https://insights.sbomify.com/CVE-2024-56158/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56158
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56158
- OSV: https://osv.dev/vulnerability/CVE-2024-56158

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56158/
Summaries are generated and may contain mistakes; the official description above is the record.
