# CVE-2024-56180: Apache EventMesh: raft Hessian Deserialization Vulnerability allowing remote code execution

> Attackers can achieve remote code execution via Hessian deserialization in the Apache EventMesh raft plugin module.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2025
- **Updated:** 18 Feb 2025
- **Also known as:** GHSA-ffvr-gmp3-xx43, ROOT-OS-UBUNTU-2204-CVE-2024-56180

## What is CVE-2024-56180?

CVE-2024-56180 is a critical unsafe deserialization vulnerability in Apache EventMesh, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CWE-502 Deserialization of Untrusted Data at the eventmesh-meta-raft plugin module in Apache EventMesh master branch without release version on windows\linux\mac os e.g. platforms allows attackers to send controlled message and remote code execute via hessian deserialization rpc protocol. Users can use the code under the master branch in project repo or version 1.11.0 to fix this issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-56180?

2 open source packages ship an affected version, including org.apache.eventmesh:eventmesh-meta-raft. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.eventmesh:eventmesh-meta-raft` | Maven | From 1.10.1 | 1.11.0 |
| `org.apache.eventmesh:eventmesh-meta-raft` | Maven | From 1.10.1 | 1.11.0 |

Products: Apache Eventmesh.

## How do I fix CVE-2024-56180?

Upgrade org.apache.eventmesh:eventmesh-meta-raft to 1.11.0 or later.

## Is CVE-2024-56180 being exploited?

There is no known exploitation of CVE-2024-56180 in the wild and no public exploit code.

## Other vulnerabilities in Apache EventMesh

- [CVE-2024-39954](https://insights.sbomify.com/CVE-2024-39954/): Apache EventMesh Runtime: SSRF (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56180 and fix it if it is affected.

What it is: CVE-2024-56180 is a critical unsafe deserialization vulnerability in Apache EventMesh, published on 14 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56180 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.eventmesh:eventmesh-meta-raft (Maven): affected from 1.10.1; fixed in 1.11.0
- org.apache.eventmesh:eventmesh-meta-raft (Maven): affected from 1.10.1; fixed in 1.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56180/ (Markdown: https://insights.sbomify.com/CVE-2024-56180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56180
- OSV: https://osv.dev/vulnerability/CVE-2024-56180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56180/
Summaries are generated and may contain mistakes; the official description above is the record.
