CVE-2024-56195 Apache Traffic Server: Intercept plugins are not access controlled
Attackers can bypass access controls on intercept plugins in Apache Traffic Server, potentially gaining unauthorized access to protected functionality.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-56195?
CVE-2024-56195 is a medium-severity missing authorization vulnerability in Apache Traffic Server, published on 6 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Access Control vulnerability in Apache Traffic Server.
This issue affects Apache Traffic Server: from 9.2.0 through 9.2.8, from 10.0.0 through 10.0.3.
Users are recommended to upgrade to version 9.2.9 or 10.0.4, which fixes the issue.
Weakness: CWE-284
Which versions are affected by CVE-2024-56195?
It affects 1 product.
Products include Apache Traffic Server.
How do I fix CVE-2024-56195?
Upgrade to a fixed version.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-56195 being exploited?
There is no known exploitation of CVE-2024-56195 in the wild and no public exploit code.
Other vulnerabilities in Apache Traffic Server
Sources
Also known as DEBIAN-CVE-2024-56195, GHSA-9cqr-9w8p-9hxm, UBUNTU-CVE-2024-56195.