CVE-2024-56196 Apache Traffic Server: ACL is not fully compatible with older versions
Attackers can bypass access controls due to improper ACL implementation in Apache Traffic Server, requiring an upgrade to secure the server.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-56196?
CVE-2024-56196 is a medium-severity missing authorization vulnerability in Apache Traffic Server, published on 6 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Access Control vulnerability in Apache Traffic Server.
This issue affects Apache Traffic Server: from 10.0.0 through 10.0.3.
Users are recommended to upgrade to version 10.0.4, which fixes the issue.
Weakness: CWE-284
Which versions are affected by CVE-2024-56196?
It affects 1 product.
Products include Apache Traffic Server.
How do I fix CVE-2024-56196?
No fix has been published for CVE-2024-56196 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-56196 being exploited?
There is no known exploitation of CVE-2024-56196 in the wild and no public exploit code.
Other vulnerabilities in Apache Traffic Server
Sources
Also known as GHSA-4m6p-f924-hjw4.