# CVE-2024-56198: path-sanitizer allows bypassing the existing filters to achieve path-traversal vulnerability

> Attackers can bypass path sanitization filters to access or modify arbitrary files on the system.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2024
- **Updated:** 31 Dec 2024
- **Also known as:** GHSA-94p5-r7cc-3rpr

## What is CVE-2024-56198?

CVE-2024-56198 is a critical path traversal vulnerability in cabraviva path-sanitizer, published on 31 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

path-sanitizer is a simple lightweight npm package for sanitizing paths to prevent Path Traversal. Prior to 3.1.0, the filters can be bypassed using .=%5c which results in a path traversal. This vulnerability is fixed in 3.1.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-56198?

2 open source packages ship an affected version, including path-sanitizer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `path-sanitizer` | npm | All versions | 3.1.0 |
| `path-sanitizer` | npm | All versions | 3.1.0 |

## How do I fix CVE-2024-56198?

Upgrade path-sanitizer to 3.1.0 or later.

## Is CVE-2024-56198 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56198 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56198 and fix it if it is affected.

What it is: CVE-2024-56198 is a critical path traversal vulnerability in cabraviva path-sanitizer, published on 31 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56198 exists.

Affected packages and fixed versions:
- path-sanitizer (npm): affected all versions; fixed in 3.1.0
- path-sanitizer (npm): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56198/ (Markdown: https://insights.sbomify.com/CVE-2024-56198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56198
- OSV: https://osv.dev/vulnerability/CVE-2024-56198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56198/
Summaries are generated and may contain mistakes; the official description above is the record.
