{"answers":{"affected":"4 open source packages ship an affected version, including phpmyfaq/phpmyfaq and thorsten/phpmyfaq. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56199 exists.","fix":"No fix has been published for CVE-2024-56199 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-56199 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 2 Jan 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-56199 and fix it if it is affected.\n\nWhat it is: CVE-2024-56199 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 2 Jan 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56199 exists.\n\nAffected packages and fixed versions:\n- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.10 up to 4.0.1; no fix listed\n- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.10 up to 4.0.1; no fix listed\n- thorsten/phpmyfaq (Packagist): affected from 3.2.10 up to 4.0.1; no fix listed\n- thorsten/phpmyfaq (Packagist): affected from 3.2.10 up to 4.0.1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-56199/ (Markdown: https://insights.sbomify.com/CVE-2024-56199/index.md)","id":"CVE-2024-56199","markdown":"https://insights.sbomify.com/CVE-2024-56199/index.md","name":"CVE-2024-56199","record":{"aliases":["GHSA-ww33-jppq-qfrp"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["denial_of_service","other"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ","requires_auth":"high_privilege","summary":"Attackers can inject malicious HTML into phpMyFAQ, causing denial of service and potential phishing or defacement attacks.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":5.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"phpMyFAQ is an open source FAQ web application. Starting no later than version 3.2.10 and prior to version 4.0.2, an attacker can inject malicious HTML content into the FAQ editor at `http[:]//localhost/admin/index[.]php?action=editentry`, resulting in a complete disruption of the FAQ page's user interface. By injecting malformed HTML elements styled to cover the entire screen, an attacker can render the page unusable. This injection manipulates the page structure by introducing overlapping buttons, images, and iframes, breaking the intended layout and functionality. Exploiting this issue can lead to Denial of Service for legitimate users, damage to the user experience, and potential abuse in phishing or defacement attacks. Version 4.0.2 contains a patch for the vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"phpMyFAQ Vulnerable to Stored HTML Injection at FAQ","id":"CVE-2024-56199","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":"xss","year":"2024"},"n_packages":4,"n_references":1,"next":{"headline":"Uncontrolled Recursion and Asymmetric Resource Consumption in Altair media/file proxy","id":"CVE-2024-56200"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["3.2.10"],"last_affected":["4.0.1"],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-ww33-jppq-qfrp"},{"ecosystem":"Packagist","fixed":[],"introduced":["3.2.10"],"last_affected":["4.0.1"],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-ww33-jppq-qfrp"},{"ecosystem":"Packagist","fixed":[],"introduced":["3.2.10"],"last_affected":["4.0.1"],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-ww33-jppq-qfrp"},{"ecosystem":"Packagist","fixed":[],"introduced":["3.2.10"],"last_affected":["4.0.1"],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-ww33-jppq-qfrp"}],"prev":{"headline":"path-sanitizer allows bypassing the existing filters to achieve path-traversal vulnerability","id":"CVE-2024-56198"},"products":["phpMyFAQ"],"published":"2025-01-02","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-02","vendors":["thorsten"]},"summary":"Attackers can inject malicious HTML into phpMyFAQ, causing denial of service and potential phishing or defacement attacks.","url":"https://insights.sbomify.com/CVE-2024-56199/"}