CVE-2024-56202 Apache Traffic Server: Expect header field can unreasonably retain resource
Attackers can cause resource exhaustion in Apache Traffic Server via the Expect header, leading to denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-56202?
CVE-2024-56202 is a medium-severity denial of service vulnerability in Apache Traffic Server, published on 6 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Expected Behavior Violation vulnerability in Apache Traffic Server.
This issue affects Apache Traffic Server: from 9.0.0 through 9.2.8, from 10.0.0 through 10.0.3.
Users are recommended to upgrade to versions 9.2.9 or 10.0.4 or newer, which fixes the issue.
Weakness: CWE-440
Which versions are affected by CVE-2024-56202?
It affects 1 product.
Products include Apache Traffic Server.
How do I fix CVE-2024-56202?
Upgrade to a fixed version.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-56202 being exploited?
There is no known exploitation of CVE-2024-56202 in the wild and no public exploit code.
Other vulnerabilities in Apache Traffic Server
Sources
Also known as DEBIAN-CVE-2024-56202, GHSA-mp92-g2h5-gx86, UBUNTU-CVE-2024-56202.