# CVE-2024-56202: Apache Traffic Server: Expect header field can unreasonably retain resource

> Attackers can cause resource exhaustion in Apache Traffic Server via the Expect header, leading to denial of service.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2025
- **Updated:** 6 Mar 2025
- **Also known as:** DEBIAN-CVE-2024-56202, GHSA-mp92-g2h5-gx86, UBUNTU-CVE-2024-56202

## What is CVE-2024-56202?

CVE-2024-56202 is a medium-severity denial of service vulnerability in Apache Traffic Server, published on 6 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Expected Behavior Violation vulnerability in Apache Traffic Server.

This issue affects Apache Traffic Server: from 9.0.0 through 9.2.8, from 10.0.0 through 10.0.3.

Users are recommended to upgrade to versions 9.2.9 or 10.0.4 or newer, which fixes the issue.

Weakness: CWE-440 (Expected Behavior Violation)

## Which versions are affected by CVE-2024-56202?

It affects 1 product.


Products: Apache Traffic Server.

## How do I fix CVE-2024-56202?

Upgrade to a fixed version.

## Is CVE-2024-56202 being exploited?

There is no known exploitation of CVE-2024-56202 in the wild and no public exploit code.

## Other vulnerabilities in Apache Traffic Server

- [CVE-2014-3525](https://insights.sbomify.com/CVE-2014-3525/): Other in n/a (critical 10.0)
- [CVE-2021-43082](https://insights.sbomify.com/CVE-2021-43082/): heap-buffer-overflow with stats-over-http plugin (critical 9.8)
- [CVE-2021-35474](https://insights.sbomify.com/CVE-2021-35474/): Dynamic stack buffer overflow in cachekey plugin (critical 9.8)
- [CVE-2019-17559](https://insights.sbomify.com/CVE-2019-17559/): Other in Apache Traffic Server (critical 9.8)
- [CVE-2019-17565](https://insights.sbomify.com/CVE-2019-17565/): Other in Apache Traffic Server (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56202 and fix it if it is affected.

What it is: CVE-2024-56202 is a medium-severity denial of service vulnerability in Apache Traffic Server, published on 6 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56202 in the wild and no public exploit code.

Affected product: Apache Traffic Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56202/ (Markdown: https://insights.sbomify.com/CVE-2024-56202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56202
- OSV: https://osv.dev/vulnerability/CVE-2024-56202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56202/
Summaries are generated and may contain mistakes; the official description above is the record.
