CVE-2024-5628 Cross-site scripting in Avada (Fusion) Builder
Authenticated attackers with contributor access can inject arbitrary scripts via the fusion_button shortcode, leading to stored XSS execution on victim pages.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-5628?
CVE-2024-5628 is a medium-severity cross-site scripting vulnerability in themefusion Avada (Fusion) Builder, published on 13 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Avada | Website Builder For WordPress & eCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's fusion_button shortcode in all versions up to, and including, 3.11.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially fixed in 3.11.9. Additional hardening for alternate attack vectors was added to version 3.11.10.
Weakness: CWE-79
Which versions are affected by CVE-2024-5628?
It affects 1 product.
Products include Theme-Fusion Avada.
How do I fix CVE-2024-5628?
No fix has been published for CVE-2024-5628 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-5628 being exploited?
There is no known exploitation of CVE-2024-5628 in the wild and no public exploit code.
Other vulnerabilities in themefusion Avada (Fusion) Builder
- CVE-2023-39312 WordPress Avada theme <= 7.11.1 - Auth. Unrestricted Zip Extraction vulnerability
- CVE-2024-1468 Avada | Website Builder For WordPress & WooCommerce <= 7.11.4 - Authenticated (Contributor+) Arbitrary File Upload
- CVE-2022-41996 WordPress Avada premium theme <= 7.8.1 - Cross-Site Request Forgery (CSRF) vulnerability
- CVE-2017-18607 Cross-site request forgery in n/a
- CVE-2023-39307 WordPress Avada theme <= 7.11.1 - Authenticated Arbitrary File Upload vulnerability
Sources
Also known as GHSA-f78v-vf29-36gj.