{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-56320 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-56320 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-56320 is a critical vulnerability in gocd, published on 3 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-56320 and fix it if it is affected.\n\nWhat it is: CVE-2024-56320 is a critical vulnerability in gocd, published on 3 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-56320 in the wild and no public exploit code.\n\nAffected product: gocd. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-56320/ (Markdown: https://insights.sbomify.com/CVE-2024-56320/index.md)","id":"CVE-2024-56320","markdown":"https://insights.sbomify.com/CVE-2024-56320/index.md","name":"CVE-2024-56320","record":{"aliases":["GHSA-346h-q594-rj8j"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"GoCD continuous delivery server","requires_auth":"low_privilege","summary":"Authenticated users can escalate privileges to admin via improper authorization in the Configuration XML UI and API.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"gocd","vendor":"thoughtworks"}],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"GoCD is a continuous deliver server. GoCD versions prior to 24.5.0 are vulnerable to admin privilege escalation due to improper authorization of access to the admin \"Configuration XML\" UI feature, and its associated API. A malicious insider/existing authenticated GoCD user with an existing GoCD user account could abuse this vulnerability to access information intended only for GoCD admins, or to escalate their privileges to that of a GoCD admin in a persistent manner. it is not possible for this vulnerability to be abused prior to authentication/login. The issue is fixed in GoCD 24.5.0. GoCD users who are not able to immediate upgrade can mitigate this issue by using a reverse proxy, WAF or similar to externally block access paths with a `/go/rails/` prefix. Blocking this route causes no loss of functionality. If it is not possible to upgrade or block the above route, consider reducing the GoCD user base to more trusted set of users, including temporarily disabling use of plugins such as the guest-login-plugin, which allow limited anonymous access as a regular user account.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"GoCD vulnerable to admin privilege escalation by a malicious internal/existing authenticated user","id":"CVE-2024-56320","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2024"},"n_packages":0,"n_references":4,"next":{"headline":"GoCD can allow malicious GoCD admins to abuse backup configuration to gain additional host access","id":"CVE-2024-56321"},"packages":[],"prev":{"headline":"Denial of service in Matter","id":"CVE-2024-56319"},"products":["gocd"],"published":"2025-01-03","related":[{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2021-43290","kev_date_added":null,"published":"2022-04-14"},{"cvss_score":9.8,"headline":"Server-side request forgery in n/a","id":"CVE-2021-44659","kev_date_added":null,"published":"2021-12-22"},{"cvss_score":9.1,"headline":"Compromised agents may be able to execute remote code on GoCD Server","id":"CVE-2022-39311","kev_date_added":null,"published":"2022-10-14"},{"cvss_score":8.8,"headline":"Command Injection/Argument Injection in GoCD","id":"CVE-2022-29184","kev_date_added":null,"published":"2022-05-20"},{"cvss_score":8.8,"headline":"Command injection in n/a","id":"CVE-2021-43286","kev_date_added":null,"published":"2022-04-14"},{"cvss_score":8.8,"headline":"Cross-site request forgery in gocd","id":"CVE-2021-25924","kev_date_added":null,"published":"2021-04-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-03","vendors":["gocd"]},"summary":"Authenticated users can escalate privileges to admin via improper authorization in the Configuration XML UI and API.","url":"https://insights.sbomify.com/CVE-2024-56320/"}