# CVE-2024-56320: GoCD vulnerable to admin privilege escalation by a malicious internal/existing authenticated user

> Authenticated users can escalate privileges to admin via improper authorization in the Configuration XML UI and API.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Jan 2025
- **Updated:** 3 Jan 2025
- **Also known as:** GHSA-346h-q594-rj8j

## What is CVE-2024-56320?

CVE-2024-56320 is a critical vulnerability in gocd, published on 3 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GoCD is a continuous deliver server. GoCD versions prior to 24.5.0 are vulnerable to admin privilege escalation due to improper authorization of access to the admin "Configuration XML" UI feature, and its associated API. A malicious insider/existing authenticated GoCD user with an existing GoCD user account could abuse this vulnerability to access information intended only for GoCD admins, or to escalate their privileges to that of a GoCD admin in a persistent manner. it is not possible for this vulnerability to be abused prior to authentication/login. The issue is fixed in GoCD 24.5.0. GoCD users who are not able to immediate upgrade can mitigate this issue by using a reverse proxy, WAF or similar to externally block access paths with a `/go/rails/` prefix. Blocking this route causes no loss of functionality. If it is not possible to upgrade or block the above route, consider reducing the GoCD user base to more trusted set of users, including temporarily disabling use of plugins such as the guest-login-plugin, which allow limited anonymous access as a regular user account.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2024-56320?

It affects 1 product.


Products: Thoughtworks Gocd.

## How do I fix CVE-2024-56320?

No fix has been published for CVE-2024-56320 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-56320 being exploited?

There is no known exploitation of CVE-2024-56320 in the wild and no public exploit code.

## Other vulnerabilities in gocd

- [CVE-2021-43290](https://insights.sbomify.com/CVE-2021-43290/): Path traversal in n/a (critical 9.8)
- [CVE-2021-44659](https://insights.sbomify.com/CVE-2021-44659/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-39311](https://insights.sbomify.com/CVE-2022-39311/): Compromised agents may be able to execute remote code on GoCD Server (critical 9.1)
- [CVE-2022-29184](https://insights.sbomify.com/CVE-2022-29184/): Command Injection/Argument Injection in GoCD (high 8.8)
- [CVE-2021-43286](https://insights.sbomify.com/CVE-2021-43286/): Command injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56320 and fix it if it is affected.

What it is: CVE-2024-56320 is a critical vulnerability in gocd, published on 3 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56320 in the wild and no public exploit code.

Affected product: gocd. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56320/ (Markdown: https://insights.sbomify.com/CVE-2024-56320/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56320
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56320
- OSV: https://osv.dev/vulnerability/CVE-2024-56320

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56320/
Summaries are generated and may contain mistakes; the official description above is the record.
