# CVE-2024-56321: GoCD can allow malicious GoCD admins to abuse backup configuration to gain additional host access

> Malicious GoCD admins can abuse backup configuration to execute arbitrary scripts on the host, potentially escalating privileges in restricted environments.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Jan 2025
- **Updated:** 3 Jan 2025
- **Also known as:** GHSA-7jr3-gh3w-vjxq

## What is CVE-2024-56321?

CVE-2024-56321 is a low-severity command injection vulnerability in gocd, published on 3 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

GoCD is a continuous deliver server. GoCD versions 18.9.0 through 24.4.0 (inclusive) can allow GoCD admins to abuse the backup configuration "post-backup script" feature to potentially execute arbitrary scripts on the hosting server or container as GoCD's user, rather than pre-configured scripts. In practice the impact of this vulnerability is limited, as in most configurations a user who can log into the GoCD UI as an admin also has host administration permissions for the host/container that GoCD runs on, in order to manage artifact storage and other service-level configuration options. Additionally, since a GoCD admin has ability to configure and schedule pipelines tasks on all GoCD agents available to the server, the fundamental functionality of GoCD allows co-ordinated task execution similar to that of post-backup-scripts. However in restricted environments where the host administration is separated from the role of a GoCD admin, this may be unexpected. The issue is fixed in GoCD 24.5.0. Post-backup scripts can no longer be executed from within certain sensitive locations on the GoCD server. No known workarounds are available.

Weakness: CWE-36 (Absolute Path Traversal), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-56321?

It affects 1 product.


Products: Thoughtworks Gocd.

## How do I fix CVE-2024-56321?

No fix has been published for CVE-2024-56321 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-56321 being exploited?

There is no known exploitation of CVE-2024-56321 in the wild and no public exploit code.

## Other vulnerabilities in gocd

- [CVE-2021-43290](https://insights.sbomify.com/CVE-2021-43290/): Path traversal in n/a (critical 9.8)
- [CVE-2021-44659](https://insights.sbomify.com/CVE-2021-44659/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2024-56320](https://insights.sbomify.com/CVE-2024-56320/): GoCD vulnerable to admin privilege escalation by a malicious internal/existing authenticated user (critical 9.4)
- [CVE-2022-39311](https://insights.sbomify.com/CVE-2022-39311/): Compromised agents may be able to execute remote code on GoCD Server (critical 9.1)
- [CVE-2022-29184](https://insights.sbomify.com/CVE-2022-29184/): Command Injection/Argument Injection in GoCD (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56321 and fix it if it is affected.

What it is: CVE-2024-56321 is a low-severity command injection vulnerability in gocd, published on 3 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56321 in the wild and no public exploit code.

Affected product: gocd. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56321/ (Markdown: https://insights.sbomify.com/CVE-2024-56321/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56321
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56321
- OSV: https://osv.dev/vulnerability/CVE-2024-56321

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56321/
Summaries are generated and may contain mistakes; the official description above is the record.
