{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-56322 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-56322 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-56322 is a low-severity vulnerability in gocd, published on 3 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-56322 and fix it if it is affected.\n\nWhat it is: CVE-2024-56322 is a low-severity vulnerability in gocd, published on 3 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-56322 in the wild and no public exploit code.\n\nAffected product: gocd. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-56322/ (Markdown: https://insights.sbomify.com/CVE-2024-56322/index.md)","id":"CVE-2024-56322","markdown":"https://insights.sbomify.com/CVE-2024-56322/index.md","name":"CVE-2024-56322","record":{"aliases":["GHSA-8xwx-hf68-8xq7"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"GoCD continuous delivery server","requires_auth":"high_privilege","summary":"GoCD admins can exploit an unused XML configuration feature to perform XXE injection, potentially reading data or causing denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"gocd","vendor":"thoughtworks"}],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"GoCD is a continuous deliver server. GoCD versions 16.7.0 through 24.4.0 (inclusive) can allow GoCD admins to abuse a hidden/unused configuration repository (pipelines as code) feature to allow XML External Entity (XXE) injection on the GoCD Server which will be executed when GoCD periodically scans configuration repositories for pipeline updates, or is triggered by an administrator or config repo admin. In practice the impact of this vulnerability is limited, in most cases without combining with another vulnerability, as only GoCD (super) admins have the ability to abuse this vulnerability. Typically a malicious GoCD admin can cause much larger damage than that they can do with XXE injection. The issue is fixed in GoCD 24.5.0. As a workaround, prevent external access from the GoCD server to arbitrary locations using some kind of environment egress control.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"GoCD vulnerable to XXE injection via abuse of unused XML configuration repository functionality","id":"CVE-2024-56322","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xxe","year":"2024"},"n_packages":0,"n_references":4,"next":{"headline":"OpenFGA Authorization Bypass","id":"CVE-2024-56323"},"packages":[],"prev":{"headline":"GoCD can allow malicious GoCD admins to abuse backup configuration to gain additional host access","id":"CVE-2024-56321"},"products":["gocd"],"published":"2025-01-03","related":[{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2021-43290","kev_date_added":null,"published":"2022-04-14"},{"cvss_score":9.8,"headline":"Server-side request forgery in n/a","id":"CVE-2021-44659","kev_date_added":null,"published":"2021-12-22"},{"cvss_score":9.4,"headline":"GoCD vulnerable to admin privilege escalation by a malicious internal/existing authenticated user","id":"CVE-2024-56320","kev_date_added":null,"published":"2025-01-03"},{"cvss_score":9.1,"headline":"Compromised agents may be able to execute remote code on GoCD Server","id":"CVE-2022-39311","kev_date_added":null,"published":"2022-10-14"},{"cvss_score":8.8,"headline":"Command Injection/Argument Injection in GoCD","id":"CVE-2022-29184","kev_date_added":null,"published":"2022-05-20"},{"cvss_score":8.8,"headline":"Command injection in n/a","id":"CVE-2021-43286","kev_date_added":null,"published":"2022-04-14"},{"cvss_score":8.8,"headline":"Cross-site request forgery in gocd","id":"CVE-2021-25924","kev_date_added":null,"published":"2021-04-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-03","vendors":["gocd"]},"summary":"GoCD admins can exploit an unused XML configuration feature to perform XXE injection, potentially reading data or causing denial of service.","url":"https://insights.sbomify.com/CVE-2024-56322/"}