# CVE-2024-56322: GoCD vulnerable to XXE injection via abuse of unused XML configuration repository functionality

> GoCD admins can exploit an unused XML configuration feature to perform XXE injection, potentially reading data or causing denial of service.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Jan 2025
- **Updated:** 3 Jan 2025
- **Also known as:** GHSA-8xwx-hf68-8xq7

## What is CVE-2024-56322?

CVE-2024-56322 is a low-severity vulnerability in gocd, published on 3 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

GoCD is a continuous deliver server. GoCD versions 16.7.0 through 24.4.0 (inclusive) can allow GoCD admins to abuse a hidden/unused configuration repository (pipelines as code) feature to allow XML External Entity (XXE) injection on the GoCD Server which will be executed when GoCD periodically scans configuration repositories for pipeline updates, or is triggered by an administrator or config repo admin. In practice the impact of this vulnerability is limited, in most cases without combining with another vulnerability, as only GoCD (super) admins have the ability to abuse this vulnerability. Typically a malicious GoCD admin can cause much larger damage than that they can do with XXE injection. The issue is fixed in GoCD 24.5.0. As a workaround, prevent external access from the GoCD server to arbitrary locations using some kind of environment egress control.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2024-56322?

It affects 1 product.


Products: Thoughtworks Gocd.

## How do I fix CVE-2024-56322?

No fix has been published for CVE-2024-56322 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-56322 being exploited?

There is no known exploitation of CVE-2024-56322 in the wild and no public exploit code.

## Other vulnerabilities in gocd

- [CVE-2021-43290](https://insights.sbomify.com/CVE-2021-43290/): Path traversal in n/a (critical 9.8)
- [CVE-2021-44659](https://insights.sbomify.com/CVE-2021-44659/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2024-56320](https://insights.sbomify.com/CVE-2024-56320/): GoCD vulnerable to admin privilege escalation by a malicious internal/existing authenticated user (critical 9.4)
- [CVE-2022-39311](https://insights.sbomify.com/CVE-2022-39311/): Compromised agents may be able to execute remote code on GoCD Server (critical 9.1)
- [CVE-2022-29184](https://insights.sbomify.com/CVE-2022-29184/): Command Injection/Argument Injection in GoCD (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56322 and fix it if it is affected.

What it is: CVE-2024-56322 is a low-severity vulnerability in gocd, published on 3 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56322 in the wild and no public exploit code.

Affected product: gocd. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56322/ (Markdown: https://insights.sbomify.com/CVE-2024-56322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56322
- OSV: https://osv.dev/vulnerability/CVE-2024-56322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56322/
Summaries are generated and may contain mistakes; the official description above is the record.
