CVE-2024-56323 OpenFGA Authorization Bypass
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2024-56323?
CVE-2024-56323 is a medium-severity vulnerability in openfga, published on 13 Jan 2025.
Official description
OpenFGA is an authorization/permission engine. IN OpenFGA v1.3.8 to v1.8.2 (Helm chart openfga-0.1.38 to openfga-0.2.19, docker v1.3.8 to v.1.8.2) are vulnerable to authorization bypass under the following conditions: 1. calling Check API or ListObjects with a model that uses [conditions](https://openfga.dev/docs/modeling/conditions), and 2. calling Check API or ListObjects API with [contextual tuples](https://openfga.dev/docs/concepts#what-are-contextual-tuples) that include conditions and 3. OpenFGA is configured with caching enabled (`OPENFGA_CHECK_QUERY_CACHE_ENABLED`). Users are advised to upgrade to v1.8.3. There are no known workarounds for this vulnerability.
Weakness: CWE-285
Which versions are affected by CVE-2024-56323?
3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/openfga/openfga Go | From 1.3.8 | 1.8.3 |
github.com/openfga/openfga Go | From 1.3.8 | 1.8.3 |
github.com/openfga/openfga Go | From 1.3.8 | 1.8.3 |
Products include Openfga Helm Charts, Openfga Openfga.
How do I fix CVE-2024-56323?
Upgrade github.com/openfga/openfga to 1.8.3 or later.
Is CVE-2024-56323 being exploited?
There is no known exploitation of CVE-2024-56323 in the wild and no public exploit code.
Other vulnerabilities in openfga
Sources
Also known as GHSA-32q6-rr98-cjqv, GO-2025-3384, MINI-3383-7m7v-64jx, MINI-34h5-mgww-gv4h.