{"answers":{"affected":"3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-56323 in the wild and no public exploit code.","fix":"Upgrade github.com/openfga/openfga to 1.8.3 or later.","what":"CVE-2024-56323 is a medium-severity vulnerability in openfga, published on 13 Jan 2025."},"fix_prompt":"Check this codebase for CVE-2024-56323 and fix it if it is affected.\n\nWhat it is: CVE-2024-56323 is a medium-severity vulnerability in openfga, published on 13 Jan 2025. \nExploitation: There is no known exploitation of CVE-2024-56323 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/openfga/openfga (Go): affected from 1.3.8; fixed in 1.8.3\n- github.com/openfga/openfga (Go): affected from 1.3.8; fixed in 1.8.3\n- github.com/openfga/openfga (Go): affected from 1.3.8; fixed in 1.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-56323/ (Markdown: https://insights.sbomify.com/CVE-2024-56323/index.md)","id":"CVE-2024-56323","markdown":"https://insights.sbomify.com/CVE-2024-56323/index.md","name":"CVE-2024-56323","record":{"aliases":["GHSA-32q6-rr98-cjqv","GO-2025-3384","MINI-3383-7m7v-64jx","MINI-34h5-mgww-gv4h"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"helm_charts","vendor":"openfga"},{"product":"openfga","vendor":"openfga"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"OpenFGA is an authorization/permission engine. IN OpenFGA v1.3.8 to v1.8.2 (Helm chart openfga-0.1.38 to openfga-0.2.19, docker v1.3.8 to v.1.8.2)  are vulnerable to authorization bypass under the following conditions: 1. calling Check API or ListObjects with a model that uses [conditions](https://openfga.dev/docs/modeling/conditions), and 2. calling Check API or ListObjects API with [contextual tuples](https://openfga.dev/docs/concepts#what-are-contextual-tuples) that include conditions and 3. OpenFGA is configured with caching enabled (`OPENFGA_CHECK_QUERY_CACHE_ENABLED`). Users are advised to upgrade to v1.8.3. There are no known workarounds for this vulnerability.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenFGA Authorization Bypass","id":"CVE-2024-56323","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":null,"year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"GoCD vulnerable to XXE injection via abuse of pipeline XML \"snippet\" editing by group admins","id":"CVE-2024-56324"},"packages":[{"ecosystem":"Go","fixed":["1.8.3"],"introduced":["1.3.8"],"last_affected":[],"package":"github.com/openfga/openfga","purl":null,"source":"GHSA-32q6-rr98-cjqv"},{"ecosystem":"Go","fixed":["1.8.3"],"introduced":["1.3.8"],"last_affected":[],"package":"github.com/openfga/openfga","purl":"pkg:golang/github.com/openfga/openfga","source":"GHSA-32q6-rr98-cjqv"},{"ecosystem":"Go","fixed":["1.8.3"],"introduced":["1.3.8"],"last_affected":[],"package":"github.com/openfga/openfga","purl":"pkg:golang/github.com/openfga/openfga","source":"GO-2025-3384"}],"prev":{"headline":"GoCD vulnerable to XXE injection via abuse of unused XML configuration repository functionality","id":"CVE-2024-56322"},"products":["openfga"],"published":"2025-01-13","related":[{"cvss_score":6.8,"headline":"OpenFGA: OIDC audience validation skipped when --authn-oidc-audience is unset","id":"CVE-2026-55689","kev_date_added":null,"published":"2026-07-09"},{"cvss_score":5.8,"headline":"OpenFGA Improper Policy Enforcement","id":"CVE-2026-24851","kev_date_added":null,"published":"2026-02-06"},{"cvss_score":5.8,"headline":"OpenFGA Improper Policy Enforcement","id":"CVE-2025-64751","kev_date_added":null,"published":"2025-11-21"},{"cvss_score":5.8,"headline":"OpenFGA Authorization Bypass (Check)","id":"CVE-2025-55213","kev_date_added":null,"published":"2025-08-18"},{"cvss_score":5.8,"headline":"OpenFGA Authorization Bypass","id":"CVE-2025-48371","kev_date_added":null,"published":"2025-05-22"},{"cvss_score":5.8,"headline":"OpenFGA Authorization Bypass","id":"CVE-2025-46331","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":5.8,"headline":"OpenFGA Authorization Bypass","id":"CVE-2025-25196","kev_date_added":null,"published":"2025-02-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-14","vendors":["openfga"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-56323/"}