# CVE-2024-56323: OpenFGA Authorization Bypass


- **Severity:** Medium 5.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 Jan 2025
- **Updated:** 14 Jan 2025
- **Also known as:** GHSA-32q6-rr98-cjqv, GO-2025-3384, MINI-3383-7m7v-64jx, MINI-34h5-mgww-gv4h

## What is CVE-2024-56323?

CVE-2024-56323 is a medium-severity vulnerability in openfga, published on 13 Jan 2025. 

### Official description

OpenFGA is an authorization/permission engine. IN OpenFGA v1.3.8 to v1.8.2 (Helm chart openfga-0.1.38 to openfga-0.2.19, docker v1.3.8 to v.1.8.2)  are vulnerable to authorization bypass under the following conditions: 1. calling Check API or ListObjects with a model that uses [conditions](https://openfga.dev/docs/modeling/conditions), and 2. calling Check API or ListObjects API with [contextual tuples](https://openfga.dev/docs/concepts#what-are-contextual-tuples) that include conditions and 3. OpenFGA is configured with caching enabled (`OPENFGA_CHECK_QUERY_CACHE_ENABLED`). Users are advised to upgrade to v1.8.3. There are no known workarounds for this vulnerability.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2024-56323?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | From 1.3.8 | 1.8.3 |
| `github.com/openfga/openfga` | Go | From 1.3.8 | 1.8.3 |
| `github.com/openfga/openfga` | Go | From 1.3.8 | 1.8.3 |

Products: Openfga Helm Charts, Openfga Openfga.

## How do I fix CVE-2024-56323?

Upgrade github.com/openfga/openfga to 1.8.3 or later.

## Is CVE-2024-56323 being exploited?

There is no known exploitation of CVE-2024-56323 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2026-55689](https://insights.sbomify.com/CVE-2026-55689/): OpenFGA: OIDC audience validation skipped when --authn-oidc-audience is unset (medium 6.8)
- [CVE-2026-24851](https://insights.sbomify.com/CVE-2026-24851/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-64751](https://insights.sbomify.com/CVE-2025-64751/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-55213](https://insights.sbomify.com/CVE-2025-55213/): OpenFGA Authorization Bypass (Check) (medium 5.8)
- [CVE-2025-48371](https://insights.sbomify.com/CVE-2025-48371/): OpenFGA Authorization Bypass (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56323 and fix it if it is affected.

What it is: CVE-2024-56323 is a medium-severity vulnerability in openfga, published on 13 Jan 2025. 
Exploitation: There is no known exploitation of CVE-2024-56323 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected from 1.3.8; fixed in 1.8.3
- github.com/openfga/openfga (Go): affected from 1.3.8; fixed in 1.8.3
- github.com/openfga/openfga (Go): affected from 1.3.8; fixed in 1.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56323/ (Markdown: https://insights.sbomify.com/CVE-2024-56323/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56323
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56323
- OSV: https://osv.dev/vulnerability/CVE-2024-56323

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56323/
Summaries are generated and may contain mistakes; the official description above is the record.
