# CVE-2024-56328: HTMLi(XSS without CSP) via Onebox urls in Discourse

> Attackers can execute arbitrary JavaScript via malicious onebox URLs in Discourse when Content Security Policy is disabled.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2025
- **Updated:** 12 Feb 2025
- **Also known as:** BIT-discourse-2024-56328, GHSA-j855-mhxj-x6vg

## What is CVE-2024-56328?

CVE-2024-56328 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 4 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open source platform for community discussion. An attacker can execute arbitrary JavaScript on users' browsers by posting a maliciously crafted onebox url. This issue only affects sites with CSP disabled. This problem has been patched in the latest version of Discourse. Users are advised to upgrade. Users unable to upgrade should enable CSP, disable inline Oneboxes globally, or allow specific domains for Oneboxing.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-56328?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.4.0 |

Products: Discourse Discourse.

## How do I fix CVE-2024-56328?

Upgrade discourse to 3.4.0 or later.

## Is CVE-2024-56328 being exploited?

There is no known exploitation of CVE-2024-56328 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56328 and fix it if it is affected.

What it is: CVE-2024-56328 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 4 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56328 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56328/ (Markdown: https://insights.sbomify.com/CVE-2024-56328/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56328
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56328
- OSV: https://osv.dev/vulnerability/CVE-2024-56328

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56328/
Summaries are generated and may contain mistakes; the official description above is the record.
