# CVE-2024-56332: Next.js Vulnerable to Denial of Service (DoS) with Server Actions

> Attackers can cause Denial of Service or Denial of Wallet by hanging Server Actions in Next.js deployments lacking execution time limits.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jan 2025
- **Updated:** 3 Jan 2025
- **Also known as:** GHSA-7m27-7ghc-44w9, MINI-jhc3-gcgr-6vq4, ROOT-APP-NPM-CVE-2024-56332

## What is CVE-2024-56332?

CVE-2024-56332 is a medium-severity denial of service vulnerability in Vercel Next.js, published on 3 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. Starting in version 13.0.0 and prior to versions 13.5.8, 14.2.21, and 15.1.2, Next.js is vulnerable to a Denial of Service (DoS) attack that allows attackers to construct requests that leaves requests to Server Actions hanging until the hosting provider cancels the function execution. This vulnerability can also be used as a Denial of Wallet (DoW) attack when deployed in providers billing by response times. (Note: Next.js server is idle during that time and only keeps the connection open. CPU and memory footprint are low during that time.). Deployments without any protection against long running Server Action invocations are especially vulnerable. Hosting providers like Vercel or Netlify set a default maximum duration on function execution to reduce the risk of excessive billing. This is the same issue as if the incoming HTTP request has an invalid `Content-Length` header or never closes. If the host has no other mitigations to those then this vulnerability is novel. This vulnerability affects only Next.js deployments using Server Actions. The issue was resolved in Next.js 13.5.8, 14.2.21, and 15.1.2. We recommend that users upgrade to a safe version. There are no official workarounds.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-56332?

6 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 13.0.0 | 13.5.8 |
| `next` | npm | From 13.0.0 | 13.5.8 |
| `next` | npm | From 14.0.0 | 14.2.21 |
| `next` | npm | From 14.0.0 | 14.2.21 |
| `next` | npm | From 15.0.0 | 15.1.2 |
| `next` | npm | From 15.0.0 | 15.1.2 |

Products: Vercel Next.js.

## How do I fix CVE-2024-56332?

Upgrade next to a fixed version for your release line: 13.5.8, 14.2.21 or 15.1.2.

## Is CVE-2024-56332 being exploited?

There is no known exploitation of CVE-2024-56332 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56332 and fix it if it is affected.

What it is: CVE-2024-56332 is a medium-severity denial of service vulnerability in Vercel Next.js, published on 3 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56332 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 13.0.0; fixed in 13.5.8
- next (npm): affected from 13.0.0; fixed in 13.5.8
- next (npm): affected from 14.0.0; fixed in 14.2.21
- next (npm): affected from 14.0.0; fixed in 14.2.21
- next (npm): affected from 15.0.0; fixed in 15.1.2
- next (npm): affected from 15.0.0; fixed in 15.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56332/ (Markdown: https://insights.sbomify.com/CVE-2024-56332/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56332
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56332
- OSV: https://osv.dev/vulnerability/CVE-2024-56332

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56332/
Summaries are generated and may contain mistakes; the official description above is the record.
