{"answers":{"affected":"2 open source packages ship an affected version, including systeminformation.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56334 exists.","fix":"Upgrade systeminformation to 5.23.7 or later.","what":"CVE-2024-56334 is a high-severity command injection vulnerability in sebhildebrandt systeminformation, published on 20 Dec 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-56334 and fix it if it is affected.\n\nWhat it is: CVE-2024-56334 is a high-severity command injection vulnerability in sebhildebrandt systeminformation, published on 20 Dec 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56334 exists.\n\nAffected packages and fixed versions:\n- systeminformation (npm): affected all versions; fixed in 5.23.7\n- systeminformation (npm): affected all versions; fixed in 5.23.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-56334/ (Markdown: https://insights.sbomify.com/CVE-2024-56334/index.md)","id":"CVE-2024-56334","markdown":"https://insights.sbomify.com/CVE-2024-56334/index.md","name":"CVE-2024-56334","record":{"aliases":["DEBIAN-CVE-2024-56334","GHSA-cvv5-9h9w-qp2m","UBUNTU-CVE-2024-56334"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Node.js system info library","requires_auth":"none","summary":"Attackers can execute arbitrary OS commands via unsanitized SSID input in the systeminformation library, potentially leading to remote code execution or privilege escalation.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"systeminformation is a System and OS information library for node.js. In affected versions SSIDs are not sanitized when before they are passed as a parameter to cmd.exe in the `getWindowsIEEE8021x` function. This means that malicious content in the SSID can be executed as OS commands. This vulnerability may enable an attacker, depending on how the package is used, to perform remote code execution or local privilege escalation. This issue has been addressed in version 5.23.7 and all users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Command injection vulnerability in getWindowsIEEE8021x (SSID) function in systeminformation","id":"CVE-2024-56334","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Privilege escalation allows organization groups to be updated/deleted if their UUID is known in vaultwarden","id":"CVE-2024-56335"},"packages":[{"ecosystem":"npm","fixed":["5.23.7"],"introduced":["0"],"last_affected":[],"package":"systeminformation","purl":null,"source":"GHSA-cvv5-9h9w-qp2m"},{"ecosystem":"npm","fixed":["5.23.7"],"introduced":["0"],"last_affected":[],"package":"systeminformation","purl":"pkg:npm/systeminformation","source":"GHSA-cvv5-9h9w-qp2m"}],"prev":{"headline":"Remote code execution in onyxia-api","id":"CVE-2024-56333"},"products":["systeminformation"],"published":"2024-12-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-12-24","vendors":["sebhildebrandt"]},"summary":"Attackers can execute arbitrary OS commands via unsanitized SSID input in the systeminformation library, potentially leading to remote code execution or privilege escalation.","url":"https://insights.sbomify.com/CVE-2024-56334/"}