# CVE-2024-56334: Command injection vulnerability in getWindowsIEEE8021x (SSID) function in systeminformation

> Attackers can execute arbitrary OS commands via unsanitized SSID input in the systeminformation library, potentially leading to remote code execution or privilege escalation.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Dec 2024
- **Updated:** 24 Dec 2024
- **Also known as:** DEBIAN-CVE-2024-56334, GHSA-cvv5-9h9w-qp2m, UBUNTU-CVE-2024-56334

## What is CVE-2024-56334?

CVE-2024-56334 is a high-severity command injection vulnerability in sebhildebrandt systeminformation, published on 20 Dec 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

systeminformation is a System and OS information library for node.js. In affected versions SSIDs are not sanitized when before they are passed as a parameter to cmd.exe in the `getWindowsIEEE8021x` function. This means that malicious content in the SSID can be executed as OS commands. This vulnerability may enable an attacker, depending on how the package is used, to perform remote code execution or local privilege escalation. This issue has been addressed in version 5.23.7 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-56334?

2 open source packages ship an affected version, including systeminformation.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `systeminformation` | npm | All versions | 5.23.7 |
| `systeminformation` | npm | All versions | 5.23.7 |

## How do I fix CVE-2024-56334?

Upgrade systeminformation to 5.23.7 or later.

## Is CVE-2024-56334 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56334 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56334 and fix it if it is affected.

What it is: CVE-2024-56334 is a high-severity command injection vulnerability in sebhildebrandt systeminformation, published on 20 Dec 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56334 exists.

Affected packages and fixed versions:
- systeminformation (npm): affected all versions; fixed in 5.23.7
- systeminformation (npm): affected all versions; fixed in 5.23.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56334/ (Markdown: https://insights.sbomify.com/CVE-2024-56334/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56334
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56334
- OSV: https://osv.dev/vulnerability/CVE-2024-56334

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56334/
Summaries are generated and may contain mistakes; the official description above is the record.
