CVE-2024-56337 Apache Tomcat: RCE due to TOCTOU issue in JSP compilation - CVE-2024-50379 mitigation was incomplete
Attackers can achieve remote code execution via a race condition in JSP compilation when the default servlet write is enabled on case-insensitive file systems.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-56337?
CVE-2024-56337 is a critical vulnerability in Apache Tomcat, published on 20 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.0.97. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.
The mitigation for CVE-2024-50379 was incomplete.
Users running Tomcat on a case insensitive file system with the default servlet write enabled (readonly initialisation parameter set to the non-default value of false) may need additional configuration to fully mitigate CVE-2024-50379 depending on which version of Java they are using with Tomcat: - running on Java 8 or Java 11: the system property sun.io.useCanonCaches must be explicitly set to false (it defaults to true) - running on Java 17: the system property sun.io.useCanonCaches, if set, must be set to false (it defaults to false) - running on Java 21 onwards: no further configuration is required (the system property and the problematic cache have been removed)
Tomcat 11.0.3, 10.1.35 and 9.0.99 onwards will include checks that sun.io.useCanonCaches is set appropriately before allowing the default servlet to be write enabled on a case insensitive file system. Tomcat will also set sun.io.useCanonCaches to false by default where it can.
Weakness: CWE-367
Which versions are affected by CVE-2024-56337?
13 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-catalina. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.34 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.34 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.2 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.2 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.98 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.98 |
7 more packages
tomcat Bitnami | All versions | 9.0.98, 10.1.34, 11.0.2 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.34 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.34 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.2 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.2 |
org.apache.tomcat:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.98 |
org.apache.tomcat:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.98 |
Products include Apache Tomcat, Netapp Bootstrap Os.
How do I fix CVE-2024-56337?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.34, 11.0.2 or 9.0.98.
Is CVE-2024-56337 being exploited?
There is no known exploitation of CVE-2024-56337 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2024-56337, CLSA-2025-1754650455, CLSA-2026-1784164087, CLSA-2026-1784250513, CLSA-2026-1792160908, DEBIAN-CVE-2024-56337 and 4 more.