# CVE-2024-56337: Apache Tomcat: RCE due to TOCTOU issue in JSP compilation - CVE-2024-50379 mitigation was incomplete

> Attackers can achieve remote code execution via a race condition in JSP compilation when the default servlet write is enabled on case-insensitive file systems.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Dec 2024
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-tomcat-2024-56337, CLSA-2025-1754650455, CLSA-2026-1784164087, CLSA-2026-1784250513, CLSA-2026-1792160908, DEBIAN-CVE-2024-56337, GHSA-27hp-xhwr-wr2m, OESA-2025-1226, ROOT-APP-MAVEN-CVE-2024-56337, UBUNTU-CVE-2024-56337

## What is CVE-2024-56337?

CVE-2024-56337 is a critical vulnerability in Apache Tomcat, published on 20 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability in Apache Tomcat.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.0.97.
The following versions were EOL at the time the CVE was created but are 
known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions 
may also be affected.

The mitigation for CVE-2024-50379 was incomplete.

Users running Tomcat on a case insensitive file system with the default servlet write enabled (readonly initialisation 
parameter set to the non-default value of false) may need additional configuration to fully mitigate CVE-2024-50379 depending on which version of Java they are using with Tomcat:
- running on Java 8 or Java 11: the system property sun.io.useCanonCaches must be explicitly set to false (it defaults to true)
- running on Java 17: the system property sun.io.useCanonCaches, if set, must be set to false (it defaults to false)
- running on Java 21 onwards: no further configuration is required (the system property and the problematic cache have been removed)

Tomcat 11.0.3, 10.1.35 and 9.0.99 onwards will include checks that sun.io.useCanonCaches is set appropriately before allowing the default servlet to be write enabled on a case insensitive file system. Tomcat will also set sun.io.useCanonCaches to false by default where it can.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2024-56337?

13 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-catalina. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.34 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.34 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.2 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.2 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0.M1 | 9.0.98 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0.M1 | 9.0.98 |
| `tomcat` | Bitnami | All versions | 9.0.98, 10.1.34, 11.0.2 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0-M1 | 10.1.34 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0-M1 | 10.1.34 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M1 | 11.0.2 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M1 | 11.0.2 |
| `org.apache.tomcat:tomcat-embed-core` | Maven | From 9.0.0.M1 | 9.0.98 |
| `org.apache.tomcat:tomcat-embed-core` | Maven | From 9.0.0.M1 | 9.0.98 |

Products: Apache Tomcat, Netapp Bootstrap Os.

## How do I fix CVE-2024-56337?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.34, 11.0.2 or 9.0.98.

## Is CVE-2024-56337 being exploited?

There is no known exploitation of CVE-2024-56337 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56337 and fix it if it is affected.

What it is: CVE-2024-56337 is a critical vulnerability in Apache Tomcat, published on 20 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56337 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.34
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.34
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.2
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.2
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0.M1; fixed in 9.0.98
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0.M1; fixed in 9.0.98
- tomcat (Bitnami): affected all versions; fixed in 9.0.98, 10.1.34, 11.0.2
- org.apache.tomcat:tomcat-catalina (Maven): affected from 10.1.0-M1; fixed in 10.1.34
- org.apache.tomcat:tomcat-catalina (Maven): affected from 10.1.0-M1; fixed in 10.1.34
- org.apache.tomcat:tomcat-catalina (Maven): affected from 11.0.0-M1; fixed in 11.0.2
- org.apache.tomcat:tomcat-catalina (Maven): affected from 11.0.0-M1; fixed in 11.0.2
- org.apache.tomcat:tomcat-embed-core (Maven): affected from 9.0.0.M1; fixed in 9.0.98

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56337/ (Markdown: https://insights.sbomify.com/CVE-2024-56337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56337
- OSV: https://osv.dev/vulnerability/CVE-2024-56337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56337/
Summaries are generated and may contain mistakes; the official description above is the record.
