CVE-2024-56361 Stored Cross-Site Scripting (XSS) in lgsl v7.0

Medium 5.3 Published Updated

Attackers can inject malicious scripts via game server info endpoints, leading to code execution in the context of users viewing the list.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-56361?

CVE-2024-56361 is a medium-severity cross-site scripting vulnerability in tltneon lgsl, published on 26 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

LGSL (Live Game Server List) provides online status for games. Before 7.0.0, a stored cross-site scripting (XSS) vulnerability was identified in lgsl. The function lgsl_query_40 in lgsl_protocol.php has implemented an HTTP crawler. This function makes a request to the registered game server, and upon crawling the malicious /info endpoint with our payload, will render our javascript on the info page. This information is being displayed via lgsl_details.php. This vulnerability is fixed in 7.0.0.

Weakness: CWE-79

Which versions are affected by CVE-2024-56361?

2 open source packages ship an affected version, including tltneon/lgsl.

PackageAffectedFixed in
tltneon/lgsl PackagistAll versions7.0.0
tltneon/lgsl PackagistAll versions7.0.0

How do I fix CVE-2024-56361?

Upgrade tltneon/lgsl to 7.0.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-56361 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56361 exists.

Sources

Also known as GHSA-xx95-62h6-h7v3.

Is CVE-2024-56361 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free