{"answers":{"affected":"2 open source packages ship an affected version, including tltneon/lgsl.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56361 exists.","fix":"Upgrade tltneon/lgsl to 7.0.0 or later.","what":"CVE-2024-56361 is a medium-severity cross-site scripting vulnerability in tltneon lgsl, published on 26 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-56361 and fix it if it is affected.\n\nWhat it is: CVE-2024-56361 is a medium-severity cross-site scripting vulnerability in tltneon lgsl, published on 26 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56361 exists.\n\nAffected packages and fixed versions:\n- tltneon/lgsl (Packagist): affected all versions; fixed in 7.0.0\n- tltneon/lgsl (Packagist): affected all versions; fixed in 7.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-56361/ (Markdown: https://insights.sbomify.com/CVE-2024-56361/index.md)","id":"CVE-2024-56361","markdown":"https://insights.sbomify.com/CVE-2024-56361/index.md","name":"CVE-2024-56361","record":{"aliases":["GHSA-xx95-62h6-h7v3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Game server list library","requires_auth":"none","summary":"Attackers can inject malicious scripts via game server info endpoints, leading to code execution in the context of users viewing the list.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"LGSL (Live Game Server List) provides online status for games. Before 7.0.0, a stored cross-site scripting (XSS) vulnerability was identified in lgsl. The function lgsl_query_40 in lgsl_protocol.php has implemented an HTTP crawler. This function makes a request to the registered game server, and upon crawling the malicious /info endpoint with our payload, will render our javascript on the info page. This information is being displayed via lgsl_details.php. This vulnerability is fixed in 7.0.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Stored Cross-Site Scripting (XSS) in lgsl v7.0","id":"CVE-2024-56361","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Navidrome Stores JWT Secret in Plaintext in navidrome.db","id":"CVE-2024-56362"},"packages":[{"ecosystem":"Packagist","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"tltneon/lgsl","purl":null,"source":"GHSA-xx95-62h6-h7v3"},{"ecosystem":"Packagist","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"tltneon/lgsl","purl":"pkg:composer/tltneon/lgsl","source":"GHSA-xx95-62h6-h7v3"}],"prev":{"headline":"Cross-site Scripting vulnerability through HyperLink cells in grist-core","id":"CVE-2024-56359"},"products":["lgsl"],"published":"2024-12-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-27","vendors":["tltneon"]},"summary":"Attackers can inject malicious scripts via game server info endpoints, leading to code execution in the context of users viewing the list.","url":"https://insights.sbomify.com/CVE-2024-56361/"}