# CVE-2024-56361: Stored Cross-Site Scripting (XSS) in lgsl v7.0

> Attackers can inject malicious scripts via game server info endpoints, leading to code execution in the context of users viewing the list.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Dec 2024
- **Updated:** 27 Dec 2024
- **Also known as:** GHSA-xx95-62h6-h7v3

## What is CVE-2024-56361?

CVE-2024-56361 is a medium-severity cross-site scripting vulnerability in tltneon lgsl, published on 26 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

LGSL (Live Game Server List) provides online status for games. Before 7.0.0, a stored cross-site scripting (XSS) vulnerability was identified in lgsl. The function lgsl_query_40 in lgsl_protocol.php has implemented an HTTP crawler. This function makes a request to the registered game server, and upon crawling the malicious /info endpoint with our payload, will render our javascript on the info page. This information is being displayed via lgsl_details.php. This vulnerability is fixed in 7.0.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-56361?

2 open source packages ship an affected version, including tltneon/lgsl.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tltneon/lgsl` | Packagist | All versions | 7.0.0 |
| `tltneon/lgsl` | Packagist | All versions | 7.0.0 |

## How do I fix CVE-2024-56361?

Upgrade tltneon/lgsl to 7.0.0 or later.

## Is CVE-2024-56361 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56361 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56361 and fix it if it is affected.

What it is: CVE-2024-56361 is a medium-severity cross-site scripting vulnerability in tltneon lgsl, published on 26 Dec 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56361 exists.

Affected packages and fixed versions:
- tltneon/lgsl (Packagist): affected all versions; fixed in 7.0.0
- tltneon/lgsl (Packagist): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56361/ (Markdown: https://insights.sbomify.com/CVE-2024-56361/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56361
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56361
- OSV: https://osv.dev/vulnerability/CVE-2024-56361

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56361/
Summaries are generated and may contain mistakes; the official description above is the record.
