{"answers":{"affected":"2 open source packages ship an affected version, including shuchkin/simplexlsx.","exploited":"There is no known exploitation of CVE-2024-56364 in the wild and no public exploit code.","fix":"Upgrade shuchkin/simplexlsx to 1.1.13 or later.","what":"CVE-2024-56364 is a medium-severity cross-site scripting vulnerability in shuchkin simplexlsx, published on 23 Dec 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-56364 and fix it if it is affected.\n\nWhat it is: CVE-2024-56364 is a medium-severity cross-site scripting vulnerability in shuchkin simplexlsx, published on 23 Dec 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-56364 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shuchkin/simplexlsx (Packagist): affected from 1.0.12; fixed in 1.1.13\n- shuchkin/simplexlsx (Packagist): affected from 1.0.12; fixed in 1.1.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-56364/ (Markdown: https://insights.sbomify.com/CVE-2024-56364/index.md)","id":"CVE-2024-56364","markdown":"https://insights.sbomify.com/CVE-2024-56364/index.md","name":"CVE-2024-56364","record":{"aliases":["GHSA-r87q-fj25-f8jf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP Excel parsing library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary JavaScript via the toHTMLEx method in SimpleXLSX, potentially compromising users viewing malicious Excel files.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"SimpleXLSX is software for parsing and retrieving data from Excel XLSx files. Starting in 1.0.12 and ending in 1.1.13, when calling the extended toHTMLEx method, it is possible to execute arbitrary JavaScript code. This vulnerability is fixed in 1.1.13.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting vulnerability in SimpleXLSXEx::readThemeColors, SimpleXLSXEx::getColorValue and SimpleXLSX::toHTMLEx","id":"CVE-2024-56364","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class","id":"CVE-2024-56365"},"packages":[{"ecosystem":"Packagist","fixed":["1.1.13"],"introduced":["1.0.12"],"last_affected":[],"package":"shuchkin/simplexlsx","purl":null,"source":"GHSA-r87q-fj25-f8jf"},{"ecosystem":"Packagist","fixed":["1.1.13"],"introduced":["1.0.12"],"last_affected":[],"package":"shuchkin/simplexlsx","purl":"pkg:composer/shuchkin/simplexlsx","source":"GHSA-r87q-fj25-f8jf"}],"prev":{"headline":"APTRS has SSTI vulnerability","id":"CVE-2024-56363"},"products":["simplexlsx"],"published":"2024-12-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-28","vendors":["shuchkin"]},"summary":"Attackers can execute arbitrary JavaScript via the toHTMLEx method in SimpleXLSX, potentially compromising users viewing malicious Excel files.","url":"https://insights.sbomify.com/CVE-2024-56364/"}