CVE-2024-56366 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file

High 8.3 Published Updated

Attackers can execute arbitrary scripts in user browsers via reflected XSS in the Accounting sample script of the PhpSpreadsheet library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-56366?

CVE-2024-56366 is a high-severity cross-site scripting vulnerability in PHPOffice PhpSpreadsheet, published on 3 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 are vulnerable to unauthorized reflected cross-site scripting in the `Accounting.php` file. Using the `/vendor/phpoffice/phpspreadsheet/samples/Wizards/NumberFormat/Accounting.php` script, an attacker can perform a cross-site scripting attack. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

Weakness: CWE-79

Which versions are affected by CVE-2024-56366?

10 open source packages ship an affected version, including phpoffice/phpspreadsheet and phpoffice/phpexcel. It affects 1 product.

PackageAffectedFixed in
phpoffice/phpspreadsheet PackagistAll versions1.29.7
phpoffice/phpspreadsheet PackagistAll versions1.29.7
phpoffice/phpspreadsheet PackagistFrom 2.0.02.1.6
phpoffice/phpspreadsheet PackagistFrom 2.0.02.1.6
phpoffice/phpspreadsheet PackagistFrom 2.2.02.3.5
phpoffice/phpspreadsheet PackagistFrom 2.2.02.3.5
4 more packages
phpoffice/phpspreadsheet PackagistFrom 3.0.03.7.0
phpoffice/phpspreadsheet PackagistFrom 3.0.03.7.0
phpoffice/phpexcel PackagistAll versions to 1.8.2None
phpoffice/phpexcel PackagistAll versions to 1.8.2None

Products include Phpoffice Phpspreadsheet.

How do I fix CVE-2024-56366?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.29.7, 2.1.6, 2.3.5 or 3.7.0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-56366 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56366 exists.

Sources

Also known as GHSA-c6fv-7vh8-2rhr.

Is CVE-2024-56366 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free